CVE-2023-6175: Buffer Copy without Checking Size of Input ('Classic Buffer Overflow') in Wireshark
Published Mar 26, 2024
·Updated
NetScreen file parser crash
Affected Software
10 affected componentsFixes available
debian/wireshark<=2.6.20-0+deb10u4, <=2.6.20-0+deb10u7, <=3.4.10-0+deb11u1
4.0.11-1~deb12u14.2.0-1
Wireshark Wireshark>=3.6.0<=3.6.18
Wireshark Wireshark>=4.0.0<=4.0.10
alpine/wireshark>=3.6.0<4.0.11-r0
4.0.11-r0
alpine/wireshark>=3.6.0<4.0.11-r0
4.0.11-r0
alpine/wireshark>=3.6.0<4.0.11-r0
4.0.11-r0
alpine/wireshark>=3.6.0<4.0.11-r0
4.0.11-r0
alpine/wireshark>=3.6.0<4.0.11-r0
4.0.11-r0
alpine/wireshark>=3.6.0<4.0.11-r0
4.0.11-r0
alpine/wireshark>=3.6.0<4.0.11-r0
4.0.11-r0
Remediation
Information
Upgrade to versions 4.0.11, 3.6.19 or above.
Event History
Mar 26, 2024
CVE Published
via MITRE·07:30 AM
Data Sourced
via MITRE·07:30 AM
RemedyDescriptionSeverityWeakness
Data Sourced
via NVD·08:15 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·08:15 AM
DescriptionSeverityAffected Software
Frequently Asked Questions
1
What is the severity of CVE-2023-6175?
CVE-2023-6175 has been classified as a denial of service vulnerability in Wireshark.
2
How do I fix CVE-2023-6175?
To fix CVE-2023-6175, upgrade to Wireshark versions 4.0.11 or later and 4.2.0 or later.
3
Which versions of Wireshark are affected by CVE-2023-6175?
Wireshark versions from 4.0.0 to 4.0.10 and 3.6.0 to 3.6.18 are affected by CVE-2023-6175.
4
What type of attack does CVE-2023-6175 enable?
CVE-2023-6175 enables a denial of service attack via a crafted capture file.
5
Is CVE-2023-6175 a remote vulnerability?
CVE-2023-6175 is not a remote vulnerability but allows for a denial of service through a malign capture file.