CVE-2023-7207: Path Traversal

Published Dec 20, 2023
·
Updated

Debian's cpio contains a path traversal vulnerability. This issue was introduced by reverting CVE-2015-1197 patches which had caused a regression in --no-absolute-filenames. Upstream has since provided a proper fix to --no-absolute-filenames.

Affected Software

6 affected componentsFixes available
ubuntu/cpio<2.13+dfsg-2ubuntu0.4
2.13+dfsg-2ubuntu0.4
ubuntu/cpio<2.13+dfsg-7ubuntu0.1
2.13+dfsg-7ubuntu0.1
ubuntu/cpio<2.13+dfsg-7.1ubuntu0.1
2.13+dfsg-7.1ubuntu0.1
ubuntu/cpio<2.14
2.14
debian/cpio<=2.13+dfsg-7.1~deb11u1, <=2.13+dfsg-7.1
2.15+dfsg-2
GNU cpio=2.13

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade ubuntu/cpio to a version that resolves this vulnerability.

    Fixed in 2.13+dfsg-2ubuntu0.4
  2. Upgrade

    Upgrade ubuntu/cpio to a version that resolves this vulnerability.

    Fixed in 2.13+dfsg-7ubuntu0.1
  3. Upgrade

    Upgrade ubuntu/cpio to a version that resolves this vulnerability.

    Fixed in 2.13+dfsg-7.1ubuntu0.1
  4. Upgrade

    Upgrade ubuntu/cpio to a version that resolves this vulnerability.

    Fixed in 2.14
  5. Upgrade

    Upgrade debian/cpio to a version that resolves this vulnerability.

    Fixed in 2.15+dfsg-2

Event History

Dec 20, 2023
Data Sourced
via Debian·07:03 PM
SeverityAffected Software
Jan 5, 2024
CVE Published
via MITRE·12:39 AM
Data Sourced
via MITRE·12:39 AM
DescriptionSeverity
Feb 29, 2024
Data Sourced
via NVD·01:42 AM
RemedyDescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2023-7207?

CVE-2023-7207 is classified as a medium severity vulnerability due to its potential for path traversal exploits.

2

How do I fix CVE-2023-7207?

To fix CVE-2023-7207, upgrade to the patched versions of cpio: 2.13+dfsg-2ubuntu0.4 for Ubuntu Focal, 2.13+dfsg-7ubuntu0.1 for Ubuntu Jammy, 2.13+dfsg-7.1ubuntu0.1 for Ubuntu Mantic, or 2.14 for upstream releases.

3

What vulnerability does CVE-2023-7207 address?

CVE-2023-7207 addresses a path traversal vulnerability in Debian's cpio, which can be exploited due to improper handling of file paths.

4

Which systems are affected by CVE-2023-7207?

CVE-2023-7207 affects Debian and Ubuntu systems running vulnerable versions of the cpio package.

5

Is CVE-2023-7207 exploitable remotely?

Yes, CVE-2023-7207 is exploitable remotely if an attacker can manipulate file paths during the cpio extraction process.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203