CVE-2024-0207: Out-of-bounds Read in Wireshark
HTTP3 dissector crash in Wireshark 4.2.0 allows denial of service via packet injection or crafted capture file
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/wiresharkto a version that resolves this vulnerability.Fixed in 4.2.2-1 - Upgrade
Upgrade
debian/wiresharkto a version that resolves this vulnerability.Fixed in 4.0.17-0+deb12u3Fixed in 4.4.18-0+deb13u1Fixed in 4.4.19-0+deb13u1Fixed in 4.6.9-1 - Upgrade
Upgrade
Wiresharkto a version that resolves this vulnerability.Fixed in 4.2.0
Event History
Frequently Asked Questions
What is the severity of CVE-2024-0207?
CVE-2024-0207 is classified as a denial of service vulnerability.
How do I fix CVE-2024-0207?
To fix CVE-2024-0207, upgrade Wireshark to version 4.2.1 or later.
What causes the CVE-2024-0207 vulnerability?
CVE-2024-0207 is caused by a crash in the HTTP3 dissector due to packet injection or crafted capture files.
Which version of Wireshark is affected by CVE-2024-0207?
Wireshark version 4.2.0 is the affected version related to CVE-2024-0207.
Is CVE-2024-0207 exploitable in a local environment?
Yes, CVE-2024-0207 can be exploited in a local environment through malicious packet injection or crafted capture files.