CVE-2024-0209: NULL Pointer Dereference in Wireshark

Published Jan 3, 2024
·
Updated

IEEE 1609.2 dissector crash in Wireshark 4.2.0, 4.0.0 to 4.0.11, and 3.6.0 to 3.6.19 allows denial of service via packet injection or crafted capture file

Affected Software

12 affected componentsFixes available
Wireshark Wireshark>=3.6.0<=3.6.19
Wireshark Wireshark>=4.0.0<=4.0.11
Wireshark Wireshark=4.2.0
debian/wireshark<4.0.17-0+deb12u1
4.0.17-0+deb12u1
debian/wireshark<4.2.2-1
4.2.2-1
debian/wireshark<4.2.2-1
4.2.2-1
debian/wireshark
4.0.17-0+deb12u34.4.18-0+deb13u14.4.19-0+deb13u14.6.9-1
alpine/wireshark>=3.6.0<4.0.12-r0
4.0.12-r0
alpine/wireshark>=3.6.0<4.0.12-r0
4.0.12-r0
alpine/wireshark>=3.6.0<4.0.12-r0
4.0.12-r0
alpine/wireshark>=3.6.0<4.0.12-r0
4.0.12-r0
alpine/wireshark>=3.6.0<4.0.12-r0
4.0.12-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade Wireshark to a version that resolves this vulnerability.

    Fixed in 4.2.0
  2. Upgrade

    Upgrade Wireshark to a version that resolves this vulnerability.

    Fixed in 4.0.12
  3. Upgrade

    Upgrade Wireshark to a version that resolves this vulnerability.

    Fixed in 3.6.20

Event History

Jan 3, 2024
CVE Published
via MITRE·07:31 AM
Data Sourced
via MITRE·07:31 AM
RemedyDescriptionSeverityWeakness
Data Sourced
via NVD·08:15 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·08:15 AM
DescriptionSeverityAffected Software

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-0209?

CVE-2024-0209 is classified as a denial of service vulnerability that can cause Wireshark to crash.

2

How do I fix CVE-2024-0209?

To fix CVE-2024-0209, users should upgrade to a patched version of Wireshark that is not affected by this vulnerability.

3

Which versions of Wireshark are affected by CVE-2024-0209?

CVE-2024-0209 affects Wireshark versions 3.6.0 to 3.6.19, 4.0.0 to 4.0.11, and 4.2.0.

4

What causes the crash related to CVE-2024-0209?

The crash caused by CVE-2024-0209 is due to packet injection or the use of a crafted capture file.

5

Is it safe to use an affected version of Wireshark after discovering CVE-2024-0209?

Using an affected version of Wireshark poses a risk as it can be exploited to cause a denial of service.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203