CVE-2024-0210: Uncontrolled Recursion in Wireshark
Zigbee TLV dissector crash in Wireshark 4.2.0 allows denial of service via packet injection or crafted capture file
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/wiresharkto a version that resolves this vulnerability.Fixed in 4.2.2-1 - Upgrade
Upgrade
debian/wiresharkto a version that resolves this vulnerability.Fixed in 4.0.17-0+deb12u3Fixed in 4.4.18-0+deb13u1Fixed in 4.4.19-0+deb13u1Fixed in 4.6.9-1 - Upgrade
Upgrade
Wiresharkto a version that resolves this vulnerability.Fixed in 4.2.0
Event History
Frequently Asked Questions
What is the severity of CVE-2024-0210?
CVE-2024-0210 is classified as a Denial of Service vulnerability.
How do I fix CVE-2024-0210?
To fix CVE-2024-0210, upgrade Wireshark to a version later than 4.2.0.
What causes the CVE-2024-0210 vulnerability?
CVE-2024-0210 is caused by a crash in the Zigbee TLV dissector due to mishandled packet injection or crafted capture files.
Which versions of Wireshark are affected by CVE-2024-0210?
CVE-2024-0210 affects Wireshark version 4.2.0.
What can be the impact of CVE-2024-0210?
The impact of CVE-2024-0210 is a denial of service that can disrupt data packet analysis.