CVE-2024-0519: Google Chromium V8 Out-of-Bounds Memory Access Vulnerability
Chromium: CVE-2024-0519 Out of bounds memory access in V8
Other sources
Google Chromium V8 Engine contains an out-of-bounds memory access vulnerability that allows a remote attacker to potentially exploit heap corruption via a crafted HTML page. This vulnerability could affect multiple web browsers that utilize Chromium, including, but not limited to, Google Chrome, Microsoft Edge, and Opera.
— CISA
Out of bounds memory access in V8 in Google Chrome prior to 120.0.6099.224 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)
— NVD
This CVE was assigned by Chrome. Microsoft Edge (Chromium-based) ingests Chromium, which addresses this vulnerability. Please see Google Chrome Releases for more information. Google is aware of reports that an exploit for CVE-2024-0519 exists in the wild.
— Microsoft
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 120.0.6099.234 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 120.0.6099.224-1~deb12u1 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 120.0.6099.224-1 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.73-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.73-1~deb13u1Fixed in 156.0.8078.47-1Fixed in 156.0.8078.79-1 - Upgrade
Upgrade
alpine/qt5-qtwebengineto a version that resolves this vulnerability.Fixed in 5.15.16-r3 - Upgrade
Upgrade
alpine/qt5-qtwebengineto a version that resolves this vulnerability.Fixed in 5.15.16-r5 - Upgrade
Upgrade
alpine/qt6-qtwebengineto a version that resolves this vulnerability.Fixed in 6.6.1-r5 - Upgrade
Upgrade
Google Chrometo a version that resolves this vulnerability.Fixed in 120.0.6099.224
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2024-0519?
CVE-2024-0519 has been classified as a critical vulnerability that may allow for remote code execution.
How do I fix CVE-2024-0519?
To fix CVE-2024-0519, users should update Google Chrome to version 120.0.6099.234 or higher.
Which software is affected by CVE-2024-0519?
CVE-2024-0519 affects Google Chrome and Microsoft Edge (Chromium-based) up to specific versions as well as various versions of Couchbase Server and Fedora.
Is CVE-2024-0519 being actively exploited?
Yes, Google has acknowledged that CVE-2024-0519 is being actively exploited in the wild.
What is the impact of CVE-2024-0519 on users?
The impact of CVE-2024-0519 could include unauthorized access to sensitive information and potential system compromise.