CVE-2024-0760: A flood of DNS messages over TCP may make the server unstable
A flood of DNS messages over TCP may make the server unstable
Other sources
A malicious client can send many DNS messages over TCP, potentially causing the server to become unstable while the attack is in progress. The server may recover after the attack ceases. Use of ACLs will not mitigate the attack. This issue affects BIND 9 versions 9.18.1 through 9.18.27, 9.19.0 through 9.19.24, and 9.18.11-S1 through 9.18.27-S1.
— NVD
axios is vulnerable to a denial of service, caused by a regular expression denial of service (ReDoS) flaw in the format method. By sending a specially crafted regex input, a remote attacker could exploit this vulnerability to cause a denial of service condition.
— IBM
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/bindto a version that resolves this vulnerability.Fixed in 9.18.31-r0 - Upgrade
Upgrade
alpine/bindto a version that resolves this vulnerability.Fixed in 9.18.28-r0 - Upgrade
Upgrade
debian/bind9to a version that resolves this vulnerability.Fixed in 1:9.18.28-1~deb12u1 - Upgrade
Upgrade
debian/bind9to a version that resolves this vulnerability.Fixed in 1:9.20.0-1 - Upgrade
Upgrade
debian/bind9to a version that resolves this vulnerability.Fixed in 1:9.18.49-1~deb12u1Fixed in 1:9.18.49-1~deb12u3Fixed in 1:9.20.26-1~deb13u1Fixed in 1:9.20.30-1~deb13u1Fixed in 1:9.20.30-1 - Upgrade
Upgrade
BIND 9to a version that resolves this vulnerability.Fixed in 9.18.28 - Upgrade
Upgrade
BIND 9to a version that resolves this vulnerability.Fixed in 9.20.0 - Upgrade
Upgrade
BIND 9to a version that resolves this vulnerability.Fixed in 9.18.28-S1
Event History
Frequently Asked Questions
What is the severity of CVE-2024-0760?
CVE-2024-0760 is considered a high severity vulnerability due to its potential to cause instability in DNS servers under attack.
How do I fix CVE-2024-0760?
To fix CVE-2024-0760, upgrade to the fixed versions of BIND, specifically 1:9.16.50-1~deb11u2, 1:9.16.50-1~deb11u1, 1:9.18.28-1~deb12u2, or 1:9.20.4-3.
Which versions of BIND are affected by CVE-2024-0760?
CVE-2024-0760 affects BIND 9 versions from 9.18.1 through 9.18, as well as earlier versions listed.
Does using ACLs help mitigate CVE-2024-0760?
Using Access Control Lists (ACLs) will not mitigate the effects of CVE-2024-0760.
What does CVE-2024-0760 exploit in DNS servers?
CVE-2024-0760 exploits the ability of a malicious client to overwhelm DNS servers with excessive TCP messages during an attack.