CVE-2024-11596: Buffer Over-read in Wireshark
ECMP dissector crash in Wireshark 4.4.0 to 4.4.1 and 4.2.0 to 4.2.8 allows denial of service via packet injection or crafted capture file
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/wiresharkto a version that resolves this vulnerability.Fixed in 4.0.17-0+deb12u2 - Upgrade
Upgrade
debian/wiresharkto a version that resolves this vulnerability.Fixed in 4.4.2-1 - Upgrade
Upgrade
debian/wiresharkto a version that resolves this vulnerability.Fixed in 4.0.17-0+deb12u3Fixed in 4.4.18-0+deb13u1Fixed in 4.4.19-0+deb13u1Fixed in 4.6.9-1 - Upgrade
Upgrade
Wiresharkto a version that resolves this vulnerability.Fixed in 4.4.2 - Upgrade
Upgrade
Wiresharkto a version that resolves this vulnerability.Fixed in 4.2.9
Event History
Frequently Asked Questions
What is the severity of CVE-2024-11596?
CVE-2024-11596 has a severity rating that indicates a denial of service vulnerability due to a crash in the ECMP dissector.
How do I fix CVE-2024-11596?
To fix CVE-2024-11596, upgrade your Wireshark installation to version 4.4.2 or later, or 4.2.9 or later.
What systems are affected by CVE-2024-11596?
CVE-2024-11596 affects Wireshark versions between 4.4.0 to 4.4.1 and 4.2.0 to 4.2.8.
How can CVE-2024-11596 be exploited?
CVE-2024-11596 can be exploited through packet injection or by using a crafted capture file.
What are the potential consequences of CVE-2024-11596?
The potential consequence of CVE-2024-11596 is a denial of service, leading to application crashes.