CVE-2024-11668: Insufficient Session Expiration in GitLab
An issue has been discovered in GitLab CE/EE affecting all versions from 16.11 before 17.4.5, 17.5 before 17.5.3, and 17.6 before 17.6.1. Long-lived connections could potentially bypass authentication controls, allowing unauthorized access to streaming results.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 17.4.5Fixed in 17.5.3Fixed in 17.6.1 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 17.4.5 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 17.5.3 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 17.6.1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2024-11668?
The severity of CVE-2024-11668 is considered high due to the potential for unauthorized access.
How do I fix CVE-2024-11668?
To fix CVE-2024-11668, upgrade GitLab to version 17.4.5 or later, 17.5.3 or later, or 17.6.1 or later.
What versions are affected by CVE-2024-11668?
CVE-2024-11668 affects GitLab CE/EE versions from 16.11 before 17.4.5, 17.5 before 17.5.3, and 17.6 before 17.6.1.
What kind of vulnerability is CVE-2024-11668?
CVE-2024-11668 is an authentication bypass vulnerability that affects long-lived connections.
Can CVE-2024-11668 affect both GitLab CE and EE versions?
Yes, CVE-2024-11668 impacts both GitLab Community Edition (CE) and Enterprise Edition (EE) versions.