CVE-2024-12084: rsync security updates
A flaw was found in rsync. When using the --safe-links option, the rsync client fails to properly verify if a symbolic link destination sent from the server contains another symbolic link within it. This results in a path traversal vulnerability, which may lead to arbitrary file write outside the desired directory.
Other sources
A heap-based buffer overflow flaw was found in the rsync daemon. This issue is due to improper handling of attacker-controlled checksum lengths (s2length) in the code. When MAXDIGESTLEN exceeds the fixed SUMLENGTH (16 bytes), an attacker can write out of bounds in the sum2 buffer.
— NVD
A path traversal vulnerability exists in rsync. It stems from behavior enabled by the --inc-recursive option, a default-enabled option for many client options and can be enabled by the server even if not explicitly enabled by the client. When using the --inc-recursive option, a lack of proper symlink verification coupled with deduplication checks occurring on a per-file-list basis could allow a server to write files outside of the client's intended destination directory. A malicious server could write malicious files to arbitrary locations named after valid directories/paths on the client.
— OSV
rsync has been updated to version 3.4.1 which contains fixes for security vulnerabilities including CVE-2024-12084 and CVE-2024-12088.
— GitLab
Rsync: heap buffer overflow in rsync due to improper checksum length handling
— Microsoft
The vulnerability arises because the checksum length (s2length) is derived from an unvalidated protocol input (MAXDIGESTLEN), which can exceed the size of the pre-allocated buffer (SUMLENGTH), allowing attackers to exploit this behavior.
— Red Hat
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/rsyncto a version that resolves this vulnerability.Fixed in 3.4.0-r0 - Upgrade
Upgrade
debian/rsyncto a version that resolves this vulnerability.Fixed in 3.2.7-1+deb12u1 - Upgrade
Upgrade
debian/rsyncto a version that resolves this vulnerability.Fixed in 3.3.0+ds1-3 - Upgrade
Upgrade
debian/rsyncto a version that resolves this vulnerability.Fixed in 3.2.7-1+deb12u6Fixed in 3.2.7-1+deb12u5Fixed in 3.4.1+ds1-5+deb13u4Fixed in 3.5.0+ds1-0+deb13u1Fixed in 3.5.1+ds1-2 - Upgrade
Upgrade
rsyncto a version that resolves this vulnerability.Fixed in 3.4.1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2024-12084?
CVE-2024-12084 is classified as a high-severity vulnerability due to its potential for exploitation and impact on system integrity.
How do I fix CVE-2024-12084?
To fix CVE-2024-12084, upgrade to the patched versions of rsync, which include 3.2.3-4+deb11u1, 3.2.3-4+deb11u3, 3.2.7-1+deb12u2, or 3.3.0+ds1-4.
What are the consequences of exploiting CVE-2024-12084?
Exploitation of CVE-2024-12084 can lead to a heap-based buffer overflow, resulting in arbitrary code execution on the affected system.
Which versions of rsync are affected by CVE-2024-12084?
CVE-2024-12084 affects rsync versions up to and including 3.2.7-1.
Is CVE-2024-12084 specific to any operating system?
CVE-2024-12084 primarily affects the rsync daemon used in Debian-based systems.