CVE-2024-12905: Path Traversal

Published Mar 27, 2025
·
Updated

An Improper Link Resolution Before File Access ("Link Following") and Improper Limitation of a Pathname to a Restricted Directory ("Path Traversal"). This vulnerability occurs when extracting a maliciously crafted tar file, which can result in unauthorized file writes or overwrites outside the intended extraction directory. The issue is associated with index.js in the tar-fs package.

Affected Software

12 affected componentsFixes available
tar-fs tar-fs>=0.0.0, <1.16.4, >=2.0.0, <2.1.2, >=3.0.0, <3.0.8
npm/tar-fs>=3.0.0<3.0.7
3.0.7
npm/tar-fs>=2.0.0<2.1.2
2.1.2
npm/tar-fs<1.16.4
1.16.4
IBM Business Automation Insights<=25.0.0
IBM Business Automation Insights<=24.0.1
IBM Business Automation Insights<=24.0.0
Microsoft cbl2 reaper 3.1.1-18<3.1.1-18
3.1.1-18
debian/node-tar-fs<2.1.3-0+deb12u1
2.1.3-0+deb12u1
debian/node-tar-fs<3.0.8+~cs2.0.4-1
3.0.8+~cs2.0.4-1
debian/node-tar-fs<3.0.8+~cs2.0.4-1
3.0.8+~cs2.0.4-1
debian/node-tar-fs
2.1.3-0+deb12u23.0.9+~cs2.0.4-1+deb13u13.1.2+~cs2.0.4-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade npm/tar-fs to a version that resolves this vulnerability.

    Fixed in 3.0.7
  2. Upgrade

    Upgrade npm/tar-fs to a version that resolves this vulnerability.

    Fixed in 2.1.2
  3. Upgrade

    Upgrade npm/tar-fs to a version that resolves this vulnerability.

    Fixed in 1.16.4
  4. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 3.1.1-18
  5. Upgrade

    Upgrade debian/node-tar-fs to a version that resolves this vulnerability.

    Fixed in 2.1.3-0+deb12u1
  6. Upgrade

    Upgrade debian/node-tar-fs to a version that resolves this vulnerability.

    Fixed in 3.0.8+~cs2.0.4-1
  7. Upgrade

    Upgrade debian/node-tar-fs to a version that resolves this vulnerability.

    Fixed in 2.1.3-0+deb12u2Fixed in 3.0.9+~cs2.0.4-1+deb13u1Fixed in 3.1.2+~cs2.0.4-1
  8. Upgrade

    Upgrade tar-fs to a version that resolves this vulnerability.

    Fixed in 1.16.4
  9. Upgrade

    Upgrade tar-fs to a version that resolves this vulnerability.

    Fixed in 2.1.2
  10. Upgrade

    Upgrade tar-fs to a version that resolves this vulnerability.

    Fixed in 3.0.7
  11. Upgrade

    Upgrade tar-fs to a version that resolves this vulnerability.

    Fixed in 3.0.8

Event History

Mar 27, 2025
CVE Published
via MITRE·04:25 PM
Data Sourced
via MITRE·04:25 PM
DescriptionSeverityWeakness
Data Sourced
via Red Hat·05:02 PM
DescriptionSeverityAffected Software
Data Sourced
via NVD·05:15 PM
DescriptionSeverityWeakness
Data Sourced
via OSV·05:15 PM
DescriptionSeverityAffected Software
Advisory Published
via GitHub·06:31 PM
Data Sourced
via GitHub·06:31 PM
DescriptionSeverityWeaknessAffected Software
Apr 11, 2025
Data Sourced
via Microsoft·07:00 AM
DescriptionSeverityWeaknessAffected Software
Apr 24, 2025
Exploit Published
via GitHub·03:34 PM
Nov 3, 2025
Data Sourced
via IBM·12:00 AM
DescriptionAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-12905?

CVE-2024-12905 has been classified with a severity rating that indicates it poses a significant risk of unauthorized file access or system compromise.

2

How do I fix CVE-2024-12905?

To fix CVE-2024-12905, upgrade to a version of tar-fs that is not vulnerable, ensuring you are using at least version 1.16.4 or 2.1.3 and above.

3

What systems are affected by CVE-2024-12905?

CVE-2024-12905 affects tar-fs versions from 0.0.0 up to but not including 1.16.4, and versions from 2.0.0 up to but not including 2.1.3, and 3.0.0 up to but not including 3.0.9.

4

What can happen if CVE-2024-12905 is exploited?

Exploitation of CVE-2024-12905 can lead to unauthorized file writes or overwrites, potentially affecting the security of the filesystem.

5

Is CVE-2024-12905 related to path traversal vulnerabilities?

Yes, CVE-2024-12905 is related to both improper link resolution before file access and improper limitation of a pathname to a restricted directory, which may allow path traversal.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203