CVE-2024-21053: Medium severity Oracle MySQL Server vulnerability
Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: DML). Supported versions that are affected are 8.0.34 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 4.9 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H).
Other sources
Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: DML). Supported versions that are affected are 8.0.34 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server.
External References:
https://www.oracle.com/security-alerts/cpuapr2024.html#AppendixMSQL
— Red Hat
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/mysqlto a version that resolves this vulnerability.Fixed in 8.0.35
Event History
Frequently Asked Questions
Who can exploit this vulnerability?
An attacker must already have high privileges on the MySQL Server and network access through one of the affected protocols. It does not require user interaction.
What is the impact of successful exploitation?
Successful exploitation can cause MySQL Server to hang or crash repeatedly, resulting in a complete denial of service. The provided CVSS vector indicates no confidentiality or integrity impact.
Which versions are affected?
Affected supported MySQL Server versions are 8.0.34 and earlier.