CVE-2024-21891: Multiple permission model bypasses due to improper path traversal sequence sanitization

Published Feb 14, 2024
·
Updated

Node.js could allow a remote attacker to bypass security restrictions, caused by improper path traversal sequence sanitization. By using a path traversal attack, an attacker could exploit this vulnerability leading to filesystem permission model bypass.

Other sources

Node.js depends on multiple built-in utility functions to normalize paths provided to node:fs functions, which can be overwitten with user-defined implementations leading to filesystem permission model bypass through path traversal attack.

— Node.Js

Node.js depends on multiple built-in utility functions to normalize paths provided to node:fs functions, which can be overwritten with user-defined implementations leading to filesystem permission model bypass through path traversal attack.

Please note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.

— Node.Js

Affected Software

8 affected componentsFixes available
redhat/nodejs<20.11.1
20.11.1
IBM Cognos Analytics<=12.0.0-12.0.3
IBM Cognos Analytics<=11.2.0-11.2.4 FP3
Nodejs Node.js>=20.0.0<20.11.1
Nodejs Node.js>=21.0.0<21.6.2
Node.js Node.js>=20.0.0<20.11.1, >=21.0.0<21.6.2
20.11.121.6.2
Node.js Node.js>=20.0.0<20.11.1
20.11.1
Node.js Node.js>=21.0.0<21.6.2
21.6.2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/nodejs to a version that resolves this vulnerability.

    Fixed in 20.11.1
  2. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 20.11.1Fixed in 21.6.2
  3. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 20.11.1
  4. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 21.6.2

Event History

Feb 14, 2024
CVE Published
via Node.js·03:30 PM
Data Sourced
via Node.js·03:30 PM
DescriptionSeverity
Data Sourced
via Node.js·05:35 PM
Affected Software
Feb 20, 2024
CVE Published
via MITRE·01:31 AM
Data Sourced
via MITRE·01:31 AM
DescriptionSeverity
Data Sourced
via NVD·02:15 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2024-21891?

CVE-2024-21891 is classified as a high severity vulnerability due to its potential to allow remote attackers to bypass security restrictions.

2

How do I fix CVE-2024-21891?

To mitigate CVE-2024-21891, update Node.js to version 20.11.1 or apply the relevant patches for IBM Cognos Analytics.

3

What types of attacks can exploit CVE-2024-21891?

CVE-2024-21891 can be exploited through path traversal attacks, allowing unauthorized access to files in the system.

4

Which software is affected by CVE-2024-21891?

CVE-2024-21891 affects Node.js and specific versions of IBM Cognos Analytics.

5

What is the impact of CVE-2024-21891?

The impact of CVE-2024-21891 includes potential unauthorized access to the filesystem, compromising the security of the application.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203