CVE-2024-22563: High severity Openvswitch OpenvSwitch vulnerability
openvswitch 2.17.8 was discovered to contain a memory leak via the function xmalloc in openvswitch-2.17.8/lib/util.c.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/openvswitchto a version that resolves this vulnerability.Fixed in 2.17.2-4 - Upgrade
Upgrade
debian/openvswitchto a version that resolves this vulnerability.Fixed in 3.1.0-2+deb12u1Fixed in 3.5.0-1Fixed in 4.0.0-2
Event History
Frequently Asked Questions
What is the severity of CVE-2024-22563?
CVE-2024-22563 is classified with a moderate severity due to the memory leak it introduces.
How do I fix CVE-2024-22563?
To fix CVE-2024-22563, update Open vSwitch to version 2.17.9 or later where this memory leak is addressed.
What are the potential risks of CVE-2024-22563?
The risks of CVE-2024-22563 include increased memory consumption that could lead to application performance degradation or crashes.
Which versions of Open vSwitch are affected by CVE-2024-22563?
CVE-2024-22563 affects Open vSwitch version 2.17.8.
Is there a workaround for CVE-2024-22563?
Currently, there are no known effective workarounds for CVE-2024-22563, thus upgrading is recommended.