CVE-2024-22667: Buffer Overflow

Published Feb 5, 2024
·
Updated

Vim before 9.0.2142 has a stack-based buffer overflow because didsetlangmap in map.c calls sprintf to write to the error buffer that is passed down to the option callback functions.

Affected Software

14 affected componentsFixes available
ubuntu/vim<2:8.0.1453-1ubuntu1.13+
2:8.0.1453-1ubuntu1.13+
ubuntu/vim<2:8.1.2269-1ubuntu5.22
2:8.1.2269-1ubuntu5.22
ubuntu/vim<2:8.2.3995-1ubuntu2.16
2:8.2.3995-1ubuntu2.16
ubuntu/vim<2:9.0.1672-1ubuntu2.3
2:9.0.1672-1ubuntu2.3
ubuntu/vim<2:7.4.052-1ubuntu3.1+
2:7.4.052-1ubuntu3.1+
ubuntu/vim<2:9.0.2189-1
2:9.0.2189-1
ubuntu/vim<2:7.4.1689-3ubuntu1.5+
2:7.4.1689-3ubuntu1.5+
vim Vim<9.0.2142
Fedoraproject Fedora=38
Fedoraproject Fedora=39
debian/vim<2:9.0.1378-2+deb12u1
2:9.0.1378-2+deb12u1
debian/vim<2:9.0.2189-1
2:9.0.2189-1
debian/vim<2:9.0.2189-1
2:9.0.2189-1
debian/vim
2:9.0.1378-2+deb12u22:9.1.1230-22:9.1.1230-2+deb13u12:9.2.0858-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/vim to a version that resolves this vulnerability.

    Fixed in 2:9.1.0016-1Fixed in 2:9.1.0199-1
  2. Upgrade

    Upgrade ubuntu/vim to a version that resolves this vulnerability.

    Fixed in 2:8.0.1453-1ubuntu1.13+
  3. Upgrade

    Upgrade ubuntu/vim to a version that resolves this vulnerability.

    Fixed in 2:8.1.2269-1ubuntu5.22
  4. Upgrade

    Upgrade ubuntu/vim to a version that resolves this vulnerability.

    Fixed in 2:8.2.3995-1ubuntu2.16
  5. Upgrade

    Upgrade ubuntu/vim to a version that resolves this vulnerability.

    Fixed in 2:9.0.1672-1ubuntu2.3
  6. Upgrade

    Upgrade ubuntu/vim to a version that resolves this vulnerability.

    Fixed in 2:7.4.052-1ubuntu3.1+
  7. Upgrade

    Upgrade ubuntu/vim to a version that resolves this vulnerability.

    Fixed in 2:9.0.2189-1
  8. Upgrade

    Upgrade ubuntu/vim to a version that resolves this vulnerability.

    Fixed in 2:7.4.1689-3ubuntu1.5+

Event History

Feb 5, 2024
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via NVD·08:15 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·08:15 AM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-22667?

CVE-2024-22667 is classified as a high severity vulnerability due to its stack-based buffer overflow nature.

2

How do I fix CVE-2024-22667?

To fix CVE-2024-22667, update Vim to version 9.0.2142 or later.

3

What versions of Vim are affected by CVE-2024-22667?

CVE-2024-22667 affects all Vim versions before 9.0.2142.

4

Can CVE-2024-22667 be exploited remotely?

Yes, CVE-2024-22667 can potentially be exploited remotely, allowing for arbitrary code execution.

5

Which operating systems are impacted by CVE-2024-22667?

CVE-2024-22667 impacts multiple Linux distributions that package vulnerable versions of Vim.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203