CVE-2024-23850: Medium severity Microsoft cbl2 kernel 5.15.153.1-1 vulnerability

Published Jan 23, 2024
·
Updated

In btrfsgetrootref in fs/btrfs/disk-io.c in the Linux kernel through 6.7.1 there can be an assertion failure and crash because a subvolume can be read out too soon after its root item is inserted upon subvolume creation.

Other sources

In btrfsgetrootref in fs/btrfs/disk-io.c in the Linux kernel through 6.7.1, there can be an assertion failure and crash because a subvolume can be read out too soon after its root item is inserted upon subvolume creation.

— Launchpad

Affected Software

10 affected componentsFixes available
Microsoft azl3 kernel 6.6.35.1-4
Microsoft cbl2 kernel 5.15.153.1-1
Microsoft cbl2 kernel 5.15.180.1-1
Microsoft azl3 kernel 6.6.92.2-1
Microsoft cbl2 kernel 5.15.180.1-1
Linux Linux kernel<=6.7.1
debian/linux<6.1.82-1
6.1.82-1
debian/linux<6.6.7-1
6.6.7-1
debian/linux<6.6.7-1
6.6.7-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.82-1
  2. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.6.7-1
  3. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1

Event History

Jan 23, 2024
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via NVD·09:15 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·09:15 AM
DescriptionSeverityAffected Software
Jan 30, 2024
Data Sourced
via Microsoft·08:00 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-23850?

CVE-2024-23850 has been classified as a critical vulnerability due to the potential for crashes in the Linux kernel.

2

How do I fix CVE-2024-23850?

To fix CVE-2024-23850, update your Linux kernel to version 6.7.1 or later.

3

What systems are affected by CVE-2024-23850?

CVE-2024-23850 affects the Linux kernel versions up to and including 6.7.1.

4

What causes the issue in CVE-2024-23850?

The issue in CVE-2024-23850 is caused by an assertion failure due to a subvolume being read too soon after its root item is inserted.

5

Is CVE-2024-23850 exploitable in production environments?

Yes, CVE-2024-23850 is exploitable in production environments, potentially leading to system crashes.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203