CVE-2024-25768: Null Pointer Dereference
OpenDMARC 1.4.2 contains a null pointer dereference vulnerability in /OpenDMARC/libopendmarc/opendmarcpolicy.c.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/opendmarcto a version that resolves this vulnerability.Fixed in 1.4.2-5 - Upgrade
Upgrade
debian/opendmarcto a version that resolves this vulnerability.Fixed in 1.4.2-5Fixed in 1.4.2-5.1
Event History
Frequently Asked Questions
What is the severity of CVE-2024-25768?
CVE-2024-25768 is classified as a critical vulnerability due to its potential to cause application crashes and denial of service.
How do I fix CVE-2024-25768?
To fix CVE-2024-25768, upgrade OpenDMARC to version 1.4.3 or later, where the vulnerability has been addressed.
What is the impact of CVE-2024-25768?
CVE-2024-25768 can lead to a null pointer dereference, resulting in a denial of service attack.
Is CVE-2024-25768 present in earlier versions of OpenDMARC?
Yes, CVE-2024-25768 specifically affects OpenDMARC version 1.4.2 and earlier versions.
Who is affected by CVE-2024-25768?
Any users or systems running OpenDMARC version 1.4.2 are affected by CVE-2024-25768 and should take immediate action to update.