CVE-2024-2626: Out of bounds read in Swiftshader
Chromium: CVE-2024-2626 Out of bounds read in Swiftshader
Other sources
Out of bounds read in Swiftshader in Google Chrome prior to 123.0.6312.58 allowed a remote attacker to perform out of bounds memory access via a crafted HTML page. (Chromium security severity: Medium)
— MITRE
This CVE was assigned by Chrome. Microsoft Edge (Chromium-based) ingests Chromium, which addresses this vulnerability. Please see Google Chrome Releases for more information.
— Microsoft
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrome (Trace Event)to a version that resolves this vulnerability.Fixed in 123.0.6312.58 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 123.0.6312.86-1~deb12u1 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 123.0.6312.58-1 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.73-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.73-1~deb13u1Fixed in 156.0.8078.47-1Fixed in 156.0.8078.79-1 - Upgrade
Upgrade
alpine/qt6-qtwebengineto a version that resolves this vulnerability.Fixed in 6.6.1-r10 - Upgrade
Upgrade
alpine/qt6-qtwebengineto a version that resolves this vulnerability.Fixed in 6.6.3-r2 - Upgrade
Upgrade
Google Chrometo a version that resolves this vulnerability.Fixed in 123.0.6312.58
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2024-2626?
CVE-2024-2626 has been categorized as a high severity vulnerability due to its potential impact on user confidentiality and system integrity.
How do I fix CVE-2024-2626?
To address CVE-2024-2626, ensure that you update Google Chrome to version 123.0.6312.58 or later.
Which browsers are affected by CVE-2024-2626?
CVE-2024-2626 affects Google Chrome and Microsoft Edge (Chromium-based) as they both rely on the Chromium engine.
What type of vulnerability is CVE-2024-2626?
CVE-2024-2626 is an out of bounds read vulnerability, which could allow unauthorized access to sensitive data.
Is CVE-2024-2626 applicable to Fedora users?
Yes, CVE-2024-2626 affects Fedora versions 38, 39, and 40, so users should apply the relevant updates.