CVE-2024-26612: netfs, fscache: Prevent Oops in fscache_put_cache()

Published Feb 29, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

netfs, fscache: Prevent Oops in fscacheputcache()

The Linux kernel CVE team has assigned CVE-2024-26612 to this issue.

Upstream advisory: https://lore.kernel.org/linux-cve-announce/20240229155245.1571576-44-lee@kernel.org/T

Other sources

In the Linux kernel, the following vulnerability has been resolved:

netfs, fscache: Prevent Oops in fscacheputcache()

This function dereferences "cache" and then checks if it's ISERRORNULL(). Check first, then dereference.

— NVD

Affected Software

12 affected componentsFixes available
Linux Linux kernel>=5.17<6.1.76
Linux Linux kernel>=6.2<6.6.15
Linux Linux kernel>=6.7<6.7.3
Linux Linux kernel=6.8-rc1
redhat/kernel<6.1.76
6.1.76
redhat/kernel<6.6.15
6.6.15
redhat/kernel<6.7.3
6.7.3
redhat/kernel<6.8
6.8
debian/linux<6.1.76-1
6.1.76-1
debian/linux<6.6.15-1
6.6.15-1
debian/linux<6.6.15-1
6.6.15-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 5.10.223-1Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1
  2. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.1.76
  3. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.6.15
  4. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.7.3
  5. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.8

Event History

Feb 29, 2024
CVE Published
via MITRE·03:52 PM
Data Sourced
via MITRE·03:52 PM
Description
Mar 11, 2024
Data Sourced
via OSV·06:15 PM
DescriptionSeverityAffected Software
Mar 12, 2024
Data Sourced
via Red Hat·04:08 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2024-26612?

CVE-2024-26612 is considered a moderate severity vulnerability in the Linux kernel.

2

How do I fix CVE-2024-26612?

To resolve CVE-2024-26612, update your Linux kernel to version 6.1.76, 6.6.15, 6.7.3, or 6.8 for Red Hat systems or specific versions listed for Debian.

3

What systems are affected by CVE-2024-26612?

CVE-2024-26612 affects multiple kernel versions in Red Hat and Debian distributions.

4

What does CVE-2024-26612 impact in the Linux kernel?

CVE-2024-26612 can lead to an Oops condition in the fscache_put_cache() function, which may affect system stability.

5

Is there an official advisory for CVE-2024-26612?

Yes, the Linux kernel CVE team has released an advisory regarding CVE-2024-26612 detailing the vulnerability and its resolution.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203