CVE-2024-26702: iio: magnetometer: rm3100: add boundary check for the value read from RM3100_REG_TMRC

Published Apr 3, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

iio: magnetometer: rm3100: add boundary check for the value read from RM3100REGTMRC

Recently, we encounter kernel crash in function rm3100commonprobe caused by out of bound access of array rm3100samprates (because of underlying hardware failures). Add boundary check to prevent out of bound access.

Affected Software

15 affected componentsFixes available
Linux Linux kernel>=5.0<5.4.269
Linux Linux kernel>=5.5<5.10.210
Linux Linux kernel>=5.11<5.15.149
Linux Linux kernel>=5.16<6.1.79
Linux Linux kernel>=6.2<6.6.18
Linux Linux kernel>=6.7<6.7.6
Linux Linux kernel=6.8-rc1
Linux Linux kernel=6.8-rc2
Linux Linux kernel=6.8-rc3
Linux Linux kernel=6.8-rc4
Debian Debian Linux=10.0
debian/linux<6.1.82-1
6.1.82-1
debian/linux<6.7.7-1
6.7.7-1
debian/linux<6.7.7-1
6.7.7-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.82-1
  2. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.7.7-1
  3. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1
  4. Compensating control

    In the Linux kernel IIO magnetometer rm3100 driver, add a boundary check for the value read from RM3100_REG_TMRC before using it to index the rm3100_samp_rates array.

Event History

Apr 3, 2024
CVE Published
via MITRE·02:55 PM
Data Sourced
via MITRE·02:55 PM
Description
Data Sourced
via OSV·03:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-26702?

CVE-2024-26702 has been classified as a medium severity vulnerability due to potential kernel crash risks.

2

How do I fix CVE-2024-26702?

To fix CVE-2024-26702, update to a patched version of the Linux kernel, such as 5.10.223-1 or later versions.

3

What systems are affected by CVE-2024-26702?

CVE-2024-26702 affects specific Debian Linux kernel versions including 5.10.223-1, 6.1.123-1, and 6.12.11-1.

4

When was CVE-2024-26702 publicly disclosed?

CVE-2024-26702 was publicly disclosed in early 2024 as part of the Linux kernel updates.

5

What are the potential impacts of CVE-2024-26702?

The potential impacts of CVE-2024-26702 include kernel crashes leading to system instability and loss of data.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203