CVE-2024-26988: init/main.c: Fix potential static_command_line memory overflow
In the Linux kernel, the following vulnerability has been resolved:
init/main.c: Fix potential staticcommandline memory overflow
The Linux kernel CVE team has assigned CVE-2024-26988 to this issue.
Upstream advisory: https://lore.kernel.org/linux-cve-announce/2024050143-CVE-2024-26988-c304@gregkh/T
Other sources
In the Linux kernel, the following vulnerability has been resolved:
init/main.c: Fix potential staticcommandline memory overflow
We allocate memory of size 'xlen + strlen(bootcommandline) + 1' for staticcommandline, but the strings copied into staticcommandline are extracommandline and commandline, rather than extracommandline and bootcommandline.
When strlen(commandline) > strlen(bootcommandline), staticcommandline will overflow.
This patch just recovers strlen(commandline) which was miss-consolidated with strlen(bootcommandline) in the commit f5c7310ac73e ("init/main: add checks for the return value of memblockalloc()")
— NVD
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 5.15.157 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 6.1.88 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 6.6.29 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 6.8.8 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 6.9 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.90-1 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.8.9-1 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1
Event History
Frequently Asked Questions
What is the severity of CVE-2024-26988?
The severity of CVE-2024-26988 is classified as a medium risk due to the potential for a memory overflow in the Linux kernel.
How do I fix CVE-2024-26988?
To address CVE-2024-26988, users should upgrade their Linux kernel to version 5.15.157, 6.1.88, or later as specified in the remediation packages.
Which Linux kernel versions are affected by CVE-2024-26988?
CVE-2024-26988 affects several Linux kernel versions including 5.10 through 6.9, specifically those prior to the mentioned fixed versions.
What are the potential consequences of CVE-2024-26988?
Exploitation of CVE-2024-26988 could lead to instability and security vulnerabilities in systems running the impacted kernel versions.
Who is affected by CVE-2024-26988?
CVE-2024-26988 impacts users of the Linux kernel across various distributions, particularly those using affected versions from Red Hat and Debian.