CVE-2024-28085: Escape sequence injection in util-linux wall

Published Mar 27, 2024
·
Updated

wall in util-linux through 2.40 often installed with setgid tty permissions allows escape sequences to be sent to other users' terminals through argv. (Specifically escape sequences received from stdin are blocked but escape sequences received from argv are not blocked.) There may be plausible scenarios where this leads to account takeover.

Other sources

wall in util-linux through 2.40, often installed with setgid tty permissions, allows escape sequences to be sent to other users' terminals through argv. (Specifically, escape sequences received from stdin are blocked, but escape sequences received from argv are not blocked.) There may be plausible scenarios where this leads to account takeover.

— Ubuntu

Affected Software

17 affected componentsFixes available
ubuntu/util-linux<2.34-0.1ubuntu9.5
2.34-0.1ubuntu9.5
ubuntu/util-linux<2.37.2-4ubuntu3.3
2.37.2-4ubuntu3.3
ubuntu/util-linux<2.39.1-4ubuntu2.1
2.39.1-4ubuntu2.1
ubuntu/util-linux<2.39.3-9ubuntu6
2.39.3-9ubuntu6
Microsoft cbl2 util-linux 2.37.4-9
Microsoft azl3 util-linux 2.39.2-2
kernel util-linux>=2.24<2.39.4
Debian Debian Linux=10.0
alpine/util-linux>=2.24<2.40-r0
2.40-r0
alpine/util-linux>=2.24<2.40-r0
2.40-r0
alpine/util-linux>=2.24<2.40-r0
2.40-r0
alpine/util-linux>=2.24<2.40-r0
2.40-r0
alpine/util-linux>=2.24<2.40-r0
2.40-r0
debian/util-linux<2.38.1-5+deb12u1
2.38.1-5+deb12u1
debian/util-linux<2.39.3-11
2.39.3-11
debian/util-linux<2.39.3-11
2.39.3-11
debian/util-linux
2.38.1-5+deb12u32.38.1-5+deb12u12.41.5-0+deb13u12.42.4-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade ubuntu/util-linux to a version that resolves this vulnerability.

    Fixed in 2.34-0.1ubuntu9.5
  2. Upgrade

    Upgrade ubuntu/util-linux to a version that resolves this vulnerability.

    Fixed in 2.37.2-4ubuntu3.3
  3. Upgrade

    Upgrade ubuntu/util-linux to a version that resolves this vulnerability.

    Fixed in 2.39.1-4ubuntu2.1
  4. Upgrade

    Upgrade ubuntu/util-linux to a version that resolves this vulnerability.

    Fixed in 2.39.3-9ubuntu6
  5. Upgrade

    Upgrade alpine/util-linux to a version that resolves this vulnerability.

    Fixed in 2.40-r0
  6. Upgrade

    Upgrade debian/util-linux to a version that resolves this vulnerability.

    Fixed in 2.38.1-5+deb12u1
  7. Upgrade

    Upgrade debian/util-linux to a version that resolves this vulnerability.

    Fixed in 2.39.3-11
  8. Upgrade

    Upgrade debian/util-linux to a version that resolves this vulnerability.

    Fixed in 2.38.1-5+deb12u3Fixed in 2.38.1-5+deb12u1Fixed in 2.41.5-0+deb13u1Fixed in 2.42.4-1

Event History

Mar 11, 2024
Exploit Published
via GitHub·12:15 AM
Mar 27, 2024
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via NVD·07:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·07:15 PM
DescriptionSeverityAffected Software
Mar 28, 2024
News Published
via BleepingComputer·09:03 PM
Apr 1, 2024
Data Sourced
via Microsoft·07:00 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-28085?

CVE-2024-28085 is classified as a vulnerability that can allow unauthorized escape sequences to affect other users' terminals.

2

How do I fix CVE-2024-28085?

To mitigate CVE-2024-28085, you should update the util-linux package to a version beyond the specified vulnerable versions listed in the advisory.

3

Which versions of util-linux are affected by CVE-2024-28085?

CVE-2024-28085 affects util-linux versions before 2.40, specifically those installed with setgid tty permissions.

4

What systems are impacted by CVE-2024-28085?

CVE-2024-28085 impacts systems running vulnerable versions of util-linux on Ubuntu and Debian distributions.

5

Can CVE-2024-28085 lead to password theft?

Yes, CVE-2024-28085 can potentially allow an attacker to create fake sudo prompts, leading to password theft.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203