CVE-2024-28219: Buffer Overflow
In imagingcms.c in Pillow before 10.3.0, a buffer overflow exists because strcpy is used instead of strncpy.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
pip/pillowto a version that resolves this vulnerability.Fixed in 10.3.0 - Upgrade
Upgrade
redhat/pillowto a version that resolves this vulnerability.Fixed in 10.3.0 - Upgrade
Upgrade
debian/pillowto a version that resolves this vulnerability.Fixed in 9.4.0-1.1+deb12u1 - Upgrade
Upgrade
debian/pillowto a version that resolves this vulnerability.Fixed in 10.3.0-1 - Upgrade
Upgrade
debian/pillowto a version that resolves this vulnerability.Fixed in 9.4.0-1.1+deb12u1Fixed in 11.1.0-5+deb13u4Fixed in 11.1.0-5+deb13u3Fixed in 12.3.0-1Fixed in 13.0.0-1 - Upgrade
Upgrade
alpine/py3-pillowto a version that resolves this vulnerability.Fixed in 10.3.0-r0 - Upgrade
Upgrade
Pillowto a version that resolves this vulnerability.Fixed in 10.3.0
Event History
Frequently Asked Questions
What is the severity of CVE-2024-28219?
CVE-2024-28219 is classified as a high-severity vulnerability due to the potential for buffer overflow exploitation.
How do I fix CVE-2024-28219?
To fix CVE-2024-28219, upgrade to Pillow version 10.3.0 or later for all affected platforms.
Which versions of Pillow are affected by CVE-2024-28219?
Pillow versions prior to 10.3.0 are affected by CVE-2024-28219.
What is the exploit mechanism for CVE-2024-28219?
CVE-2024-28219 exploits a buffer overflow resulting from the improper use of strcpy instead of strncpy.
Is CVE-2024-28219 present in Debian packages?
Yes, CVE-2024-28219 affects several Debian packages, and users should upgrade to the specified remedial versions.