CVE-2024-28248: Cilium intermittent HTTP policy bypass
Impact
Cilium's HTTP policies are not consistently applied to all traffic in the scope of the policies, leading to HTTP traffic being incorrectly and intermittently forwarded when it should be dropped.
Patches
This issue affects:
Cilium v1.13 between v1.13.9 and v1.13.12 inclusive Cilium v1.14 between v1.14.0 and v1.14.7 inclusive Cilium v1.15.0 and v1.15.1
This issue has been patched in:
Cilium v1.15.2 Cilium v1.14.8 Cilium v1.13.13
Workarounds
There is no workaround for this issue – affected users are strongly encouraged to upgrade.
Acknowledgements
The Cilium community has worked together with members of Isovalent to prepare these mitigations. Special thanks to @romikps for discovering and reporting this issue, and @sayboras and @jrajahalme for preparing the fix.
For more information
If you have any questions or comments about this advisory, please reach out on Slack.
If you think you have found a vulnerability affecting Cilium, we strongly encourage you to report it to our security mailing list at security@cilium.io. This is a private mailing list for the Cilium internal security team, and your report will be treated as top priority.
Other sources
Cilium is a networking, observability, and security solution with an eBPF-based dataplane. Starting in version 1.13.9 and prior to versions 1.13.13, 1.14.8, and 1.15.2, Cilium's HTTP policies are not consistently applied to all traffic in the scope of the policies, leading to HTTP traffic being incorrectly and intermittently forwarded when it should be dropped. This issue has been patched in Cilium 1.15.2, 1.14.8, and 1.13.13. There are no known workarounds for this issue.
— MITRE
Affected Software
Event History
Frequently Asked Questions
What is the severity of CVE-2024-28248?
CVE-2024-28248 is classified as a medium severity vulnerability affecting Cilium's HTTP policies.
How do I fix CVE-2024-28248?
To fix CVE-2024-28248, upgrade Cilium to version 1.15.2, 1.14.8, or 1.13.13 depending on your current version.
What does CVE-2024-28248 impact in Cilium?
CVE-2024-28248 impacts the consistent application of HTTP policies, causing incorrect forwarding of HTTP traffic.
Which versions of Cilium are affected by CVE-2024-28248?
CVE-2024-28248 affects Cilium versions between 1.13.9 to 1.13.13, 1.14.0 to 1.14.8, and 1.15.0 to 1.15.2.
What kind of vulnerability is CVE-2024-28248?
CVE-2024-28248 is a security vulnerability related to the incorrect handling of HTTP traffic policies in Cilium.