CVE-2024-28718: Critical severity Openstack Magnum vulnerability
An issue in OpenStack magnum yoga-eom version allows a remote attacker to execute arbitrary code via the certmanager.py. component.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
pip/magnumto a version that resolves this vulnerability.Fixed in 15.0.2 - Upgrade
Upgrade
pip/magnumto a version that resolves this vulnerability.Fixed in 16.0.2 - Upgrade
Upgrade
pip/magnumto a version that resolves this vulnerability.Fixed in 17.0.2 - Upgrade
Upgrade
pip/magnumto a version that resolves this vulnerability.Fixed in 14.1.2
Event History
Frequently Asked Questions
What is the severity of CVE-2024-28718?
CVE-2024-28718 is classified as a high severity vulnerability due to its potential for remote code execution.
How do I fix CVE-2024-28718?
To fix CVE-2024-28718, upgrade the magnum package to version 15.0.2, 16.0.2, 17.0.2, or any version higher than 14.1.2.
What component is affected in CVE-2024-28718?
The cert_manager.py component is the affected part in CVE-2024-28718.
What type of vulnerability is CVE-2024-28718?
CVE-2024-28718 is a remote code execution vulnerability.
Which software versions are impacted by CVE-2024-28718?
CVE-2024-28718 impacts OpenStack magnum versions from 15.0.0.0rc1 up to 15.0.2, 16.0.0.0rc1 up to 16.0.2, and 17.0.0.0rc1 up to 17.0.2, along with any versions prior to 14.1.2.