CVE-2024-2884: Out of bounds read in V8
Out of bounds read in V8 in Google Chrome prior to 121.0.6167.139 allowed a remote attacker to potentially perform out of bounds memory access via a crafted HTML page. (Chromium security severity: Medium)
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrome (Trace Event)to a version that resolves this vulnerability.Fixed in 121.0.6167.139 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 121.0.6167.139-1~deb12u1 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 121.0.6167.139-1 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.79-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.79-1~deb13u1Fixed in 156.0.8078.79-1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2024-2884?
CVE-2024-2884 has a Medium severity rating, indicating a potential risk for exploitation.
How do I fix CVE-2024-2884?
To fix CVE-2024-2884, users should update Google Chrome to version 121.0.6167.139 or later.
What type of vulnerability is CVE-2024-2884?
CVE-2024-2884 is an out of bounds read vulnerability in the V8 JavaScript engine of Google Chrome.
Can CVE-2024-2884 be exploited remotely?
Yes, CVE-2024-2884 can be exploited remotely through a crafted HTML page.
What versions of Google Chrome are affected by CVE-2024-2884?
CVE-2024-2884 affects all versions of Google Chrome prior to 121.0.6167.139.