CVE-2024-32475: Envoy RELEASE_ASSERT using auto_sni with :authority header > 255 bytes

Published Apr 18, 2024
·
Updated

Envoy is a cloud-native, open source edge and service proxy. When an upstream TLS cluster is used with autosni enabled, a request containing a host/:authority header longer than 255 characters triggers an abnormal termination of Envoy process. Envoy does not gracefully handle an error when setting SNI for outbound TLS connection. The error can occur when Envoy attempts to use the host/:authority header value longer than 255 characters as SNI for outbound TLS connection. SNI length is limited to 255 characters per the standard. Envoy always expects this operation to succeed and abnormally aborts the process when it fails. This vulnerability is fixed in 1.30.1, 1.29.4, 1.28.3, and 1.27.5.

Other sources

Summary: When an upstream TLS cluster is used with autosni enabled, a request containing a host/:authority (or alternate header configured via overrideautosniheader ) header longer than 255 characters triggers an abnormal termination of Envoy process.

Affected Components: TLS component for outbound connections.

Details: Envoy does not gracefully handle an error when setting SNI for outbound TLS connection. The error can occur when Envoy attempts to use the host/:authority header value longer than 255 characters as SNI for outbound TLS connection. SNI length is limited to 255 characters per the standard. Envoy always expects this operation to succeed and abnormally aborts the process when it fails.

Impact: Denial of Service due to abnormal process termination.

Attack vector(s): A client request with host/:authority header (or alternate header configured via overrideautosniheader ) longer than 255 characters that is proxied to Envoy cluster with autosni option set to true.

Patches: This bug affects all currently maintained versions (and all versions from 1.13 to 1.30): 1.27.x, 1.28.x, 1.29.x, 1.30.x.

This bug is fixed in our latest versions. Update to the following versions to resolve: =1.30.1 =1.29.4 =1.28.3 =1.27.5

References: https://github.com/envoyproxy/envoy/commit/b47fc6648d7c2dfe0093a601d44cb704b7bad382 https://github.com/envoyproxy/envoy/security/advisories/GHSA-3mh5-6q8v-25wj

— Red Hat

Affected Software

7 affected componentsFixes available
redhat/envoy<1.30.1
1.30.1
redhat/envoy<1.29.4
1.29.4
redhat/envoy<1.27.5
1.27.5
Envoyproxy Envoy>=1.13.0<1.27.5
Envoyproxy Envoy>=1.28.0<1.28.3
Envoyproxy Envoy>=1.29.0<1.29.4
Envoyproxy Envoy=1.30.0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/envoy to a version that resolves this vulnerability.

    Fixed in 1.30.1
  2. Upgrade

    Upgrade redhat/envoy to a version that resolves this vulnerability.

    Fixed in 1.29.4
  3. Upgrade

    Upgrade redhat/envoy to a version that resolves this vulnerability.

    Fixed in 1.28.3
  4. Upgrade

    Upgrade redhat/envoy to a version that resolves this vulnerability.

    Fixed in 1.27.5
  5. Upgrade

    Upgrade Envoy to a version that resolves this vulnerability.

    Fixed in 1.30.1
  6. Upgrade

    Upgrade Envoy to a version that resolves this vulnerability.

    Fixed in 1.29.4
  7. Upgrade

    Upgrade Envoy to a version that resolves this vulnerability.

    Fixed in 1.28.3
  8. Upgrade

    Upgrade Envoy to a version that resolves this vulnerability.

    Fixed in 1.27.5

Event History

Apr 18, 2024
CVE Published
via MITRE·02:18 PM
Data Sourced
via MITRE·02:18 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·03:15 PM
RemedyDescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2024-32475?

CVE-2024-32475 is considered to have a high severity due to the potential for denial of service through abnormal termination of the Envoy process.

2

How do I fix CVE-2024-32475?

To fix CVE-2024-32475, you should upgrade Envoy to version 1.30.1, 1.29.4, or 1.27.5 from Red Hat.

3

What triggers the vulnerability in CVE-2024-32475?

CVE-2024-32475 is triggered by a request containing a host or :authority header longer than 255 characters when using an upstream TLS cluster with auto_sni enabled.

4

Who is affected by CVE-2024-32475?

Users of Envoy versions prior to 1.30.1, 1.29.4, and 1.27.5 are affected by CVE-2024-32475 due to the abnormal termination risk.

5

What software does CVE-2024-32475 impact?

CVE-2024-32475 impacts the Envoy proxy software when configured with specific TLS settings.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203