CVE-2024-32664: Suricata's base64 contains an out of bounds write

Published May 7, 2024
·
Updated

Suricata is a network Intrusion Detection System, Intrusion Prevention System and Network Security Monitoring engine. Prior to 7.0.5 and 6.0.19, specially crafted traffic or datasets can cause a limited buffer overflow. This vulnerability is fixed in 7.0.5 and 6.0.19. Workarounds include not use rules with base64decode keyword with bytes option with value 1, 2 or 5 and for 7.0.x, setting app-layer.protocols.smtp.mime.body-md5 to false.

Affected Software

10 affected componentsFixes available
OISF Suricata>=6.0.0<6.0.19
OISF Suricata>=7.0.0<7.0.5
debian/suricata<1:7.0.5-1
1:7.0.5-1
debian/suricata<1:7.0.5-1
1:7.0.5-1
debian/suricata
1:7.0.10-1+deb13u41:8.0.8-1
alpine/suricata>=6.0.0<7.0.6-r0
7.0.6-r0
alpine/suricata>=6.0.0<7.0.6-r0
7.0.6-r0
alpine/suricata>=6.0.0<7.0.6-r0
7.0.6-r0
alpine/suricata>=6.0.0<7.0.6-r0
7.0.6-r0
alpine/suricata>=6.0.0<7.0.6-r0
7.0.6-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/suricata to a version that resolves this vulnerability.

    Fixed in 1:7.0.5-1
  2. Upgrade

    Upgrade debian/suricata to a version that resolves this vulnerability.

    Fixed in 1:7.0.10-1+deb13u4Fixed in 1:8.0.8-1
  3. Upgrade

    Upgrade alpine/suricata to a version that resolves this vulnerability.

    Fixed in 7.0.6-r0
  4. Upgrade

    Upgrade Suricata to a version that resolves this vulnerability.

    Fixed in 7.0.5
  5. Upgrade

    Upgrade Suricata to a version that resolves this vulnerability.

    Fixed in 6.0.19
  6. Configuration

    Do not use rules with the base64_decode keyword when the bytes option is set to 1, 2, or 5.

    Suricata base64_decode rules with bytes option = Do not use bytes values 1, 2, or 5
  7. Configuration

    For 7.0.x, set app-layer.protocols.smtp.mime.body-md5 to false.

    Suricata 7.0.x app-layer.protocols.smtp.mime.body-md5 = false

Event History

May 7, 2024
CVE Published
via MITRE·02:57 PM
Data Sourced
via MITRE·02:57 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·03:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·03:15 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2024-32664?

CVE-2024-32664 is classified as a limited buffer overflow vulnerability affecting Suricata versions prior to 6.0.19 and 7.0.5.

2

How do I fix CVE-2024-32664?

To fix CVE-2024-32664, upgrade Suricata to version 6.0.19 or 7.0.5 or later.

3

What versions of Suricata are affected by CVE-2024-32664?

CVE-2024-32664 affects Suricata versions 6.0.0 to 6.0.18 and 7.0.0 to 7.0.4.

4

What types of attacks can exploit CVE-2024-32664?

CVE-2024-32664 can be exploited through specially crafted traffic or datasets that trigger the buffer overflow.

5

Are there any workarounds for CVE-2024-32664?

Temporary workarounds for CVE-2024-32664 involve restrictions on the type of traffic processed by Suricata before the software is updated.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203