CVE-2024-34001: Moodle CSRF risk in admin preset tool management of presets
Actions in the admin preset tool did not include the necessary token to prevent a CSRF risk.
Other sources
Moodle CSRF risk in admin preset tool management of presets
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 4.1.10 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 4.2.7 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 4.3.4
Event History
Frequently Asked Questions
What is the severity of CVE-2024-34001?
CVE-2024-34001 is a medium severity vulnerability due to its CSRF risk in the admin preset tool.
How do I fix CVE-2024-34001?
To fix CVE-2024-34001, upgrade to Moodle version 4.1.10, 4.2.7, or 4.3.4.
What types of attacks does CVE-2024-34001 expose systems to?
CVE-2024-34001 exposes systems to Cross-Site Request Forgery (CSRF) attacks.
Which versions of Moodle are affected by CVE-2024-34001?
CVE-2024-34001 affects Moodle versions prior to 4.1.10 and between 4.2.0 to 4.2.7, as well as versions between 4.3.0 to 4.3.4.
Is there a patch available for CVE-2024-34001?
Yes, a patch is available by upgrading to the specified remedial versions of Moodle.