CVE-2024-34002: Moodle Authenticated LFI risk in some misconfigured shared hosting environments

Published May 31, 2024
·
Updated

In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user with both access to restore feedback modules and direct access to the web server outside of the Moodle webroot could execute a local file include.

Other sources

Moodle Authenticated LFI risk in some misconfigured shared hosting environments

— Packagist

Affected Software

9 affected componentsFixes available
composer/moodle/moodle<4.1.10
4.1.10
composer/moodle/moodle>=4.2.0<4.2.7
4.2.7
composer/moodle/moodle>=4.3.0<4.3.4
4.3.4
Moodle Moodle<4.1.10
Moodle Moodle>=4.2.0<4.2.7
Moodle Moodle>4.3.0<4.3.4
composer/moodle/moodle<4.1.10
4.1.10
composer/moodle/moodle>=4.2.0, <4.2.7
4.2.7
composer/moodle/moodle>=4.3.0, <4.3.4
4.3.4

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.1.10
  2. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.2.7
  3. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.3.4

Event History

May 31, 2024
CVE Published
via MITRE·08:15 PM
Data Sourced
via MITRE·08:15 PM
DescriptionWeakness
Data Sourced
via NVD·09:15 PM
DescriptionSeverityWeaknessAffected Software
Advisory Published
via GitHub·09:30 PM
Data Sourced
via GitHub·09:30 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·09:30 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2024-34002?

CVE-2024-34002 is considered a high severity vulnerability due to its potential for local file inclusion in a misconfigured shared hosting environment.

2

How do I fix CVE-2024-34002?

To fix CVE-2024-34002, upgrade to Moodle version 4.1.10, 4.2.7, or 4.3.4 as applicable.

3

What systems are affected by CVE-2024-34002?

CVE-2024-34002 affects Moodle installations that allow misplaced access to content in shared hosting environments.

4

What is the impact of CVE-2024-34002 on users?

Users with access to restore feedback modules may exploit CVE-2024-34002 to read unauthorized files, leading to sensitive data exposure.

5

Is there a workaround for CVE-2024-34002?

The primary mitigation for CVE-2024-34002 is to ensure proper configuration of the hosting environment to restrict unauthorized access.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203