CVE-2024-34003: Moodle Authenticated LFI risk in some misconfigured shared hosting environments

Published May 31, 2024
·
Updated

In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user with both access to restore workshop modules and direct access to the web server outside of the Moodle webroot could execute a local file include.

Other sources

Moodle Authenticated LFI risk in some misconfigured shared hosting environments

— Packagist

Affected Software

9 affected componentsFixes available
composer/moodle/moodle<4.1.10
4.1.10
composer/moodle/moodle>=4.2.0<4.2.7
4.2.7
composer/moodle/moodle>=4.3.0<4.3.4
4.3.4
Moodle Moodle<4.1.10
Moodle Moodle>=4.2.0<4.2.7
Moodle Moodle>=4.3.0<4.3.4
composer/moodle/moodle<4.1.10
4.1.10
composer/moodle/moodle>=4.2.0, <4.2.7
4.2.7
composer/moodle/moodle>=4.3.0, <4.3.4
4.3.4

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.1.10
  2. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.2.7
  3. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.3.4

Event History

May 31, 2024
CVE Published
via MITRE·08:19 PM
Data Sourced
via MITRE·08:19 PM
DescriptionWeakness
Data Sourced
via NVD·09:15 PM
DescriptionSeverityWeaknessAffected Software
Advisory Published
via GitHub·09:30 PM
Data Sourced
via GitHub·09:30 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·09:30 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2024-34003?

CVE-2024-34003 is considered a medium severity vulnerability due to the potential for local file inclusion in misconfigured shared environments.

2

How do I fix CVE-2024-34003?

To fix CVE-2024-34003, upgrade to Moodle version 4.1.10, 4.2.7, or 4.3.4.

3

What systems are affected by CVE-2024-34003?

CVE-2024-34003 affects Moodle instances that are misconfigured in a shared hosting environment allowing user access outside of the Moodle webroot.

4

Who is impacted by CVE-2024-34003?

CVE-2024-34003 can impact Moodle users who have restore workshop module access and web server access.

5

What is the risk of CVE-2024-34003?

The risk of CVE-2024-34003 includes unauthorized access to sensitive content due to local file inclusion vulnerabilities.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203