CVE-2024-34111: Magento Open Source Server-Side Request Forgery (SSRF) vulnerability

Published Jun 13, 2024
·
Updated

Adobe Commerce versions 2.4.7, 2.4.6-p5, 2.4.5-p7, 2.4.4-p8 and earlier are affected by a Server-Side Request Forgery (SSRF) vulnerability that could lead to arbitrary file system read. A low-privilege authenticated attacker can force the application to make arbitrary requests via injection of arbitrary URLs. Exploitation of this issue does not require user interaction..

Other sources

Adobe Commerce versions 2.4.7, 2.4.6-p5, 2.4.5-p7, 2.4.4-p8 and earlier are affected by a Server-Side Request Forgery (SSRF) vulnerability that could result in arbitrary code execution. An attacker could exploit this vulnerability by sending a crafted request to the server, which could then cause the server to execute arbitrary code. Exploitation of this issue does not require user interaction.

— GitHub

Magento Open Source Server-Side Request Forgery (SSRF) vulnerability

— Packagist

Affected Software

85 affected componentsFixes available
composer/magento/community-edition<2.4.4-p9
2.4.4-p9
composer/magento/community-edition>=2.4.5-p1<2.4.5-p8
2.4.5-p8
composer/magento/community-edition>=2.4.6-p1<2.4.6-p6
2.4.6-p6
composer/magento/community-edition=2.4.4
composer/magento/community-edition=2.4.5
composer/magento/community-edition=2.4.6
composer/magento/community-edition=2.4.7
Adobe Commerce=2.3.7
Adobe Commerce=2.3.7-p1
Adobe Commerce=2.3.7-p2
Adobe Commerce=2.3.7-p3
Adobe Commerce=2.3.7-p4
Adobe Commerce=2.3.7-p4-ext1
Adobe Commerce=2.3.7-p4-ext2
Adobe Commerce=2.3.7-p4-ext3
Adobe Commerce=2.3.7-p4-ext4
Adobe Commerce=2.4.0
Adobe Commerce=2.4.0-ext-1
Adobe Commerce=2.4.0-ext-2
Adobe Commerce=2.4.0-ext-3
Adobe Commerce=2.4.0-ext-4
Adobe Commerce=2.4.1
Adobe Commerce=2.4.1-ext-1
Adobe Commerce=2.4.1-ext-2
Adobe Commerce=2.4.1-ext-3
Adobe Commerce=2.4.1-ext-4
Adobe Commerce=2.4.2
Adobe Commerce=2.4.2-ext-1
Adobe Commerce=2.4.2-ext-2
Adobe Commerce=2.4.2-ext-3
Adobe Commerce=2.4.2-ext-4
Adobe Commerce=2.4.3
Adobe Commerce=2.4.3-ext-1
Adobe Commerce=2.4.3-ext-2
Adobe Commerce=2.4.3-ext-3
Adobe Commerce=2.4.3-ext-4
Adobe Commerce=2.4.4
Adobe Commerce=2.4.4-p1
Adobe Commerce=2.4.4-p2
Adobe Commerce=2.4.4-p3
Adobe Commerce=2.4.4-p4
Adobe Commerce=2.4.4-p5
Adobe Commerce=2.4.4-p6
Adobe Commerce=2.4.5
Adobe Commerce=2.4.5-p1
Adobe Commerce=2.4.5-p2
Adobe Commerce=2.4.5-p3
Adobe Commerce=2.4.5-p4
Adobe Commerce=2.4.5-p5
Adobe Commerce=2.4.6
Adobe Commerce=2.4.6-p1
Adobe Commerce=2.4.6-p2
Adobe Commerce=2.4.6-p3
Adobe Commerce Webhooks>=1.2.0<=1.4.0
Adobe Magento=2.4.4
Adobe Magento=2.4.4-p1
Adobe Magento=2.4.4-p2
Adobe Magento=2.4.4-p3
Adobe Magento=2.4.4-p4
Adobe Magento=2.4.4-p5
Adobe Magento=2.4.4-p6
Adobe Magento=2.4.4-p7
Adobe Magento=2.4.4-p8
Adobe Magento=2.4.5
Adobe Magento=2.4.5-p1
Adobe Magento=2.4.5-p2
Adobe Magento=2.4.5-p3
Adobe Magento=2.4.5-p4
Adobe Magento=2.4.5-p5
Adobe Magento=2.4.5-p6
Adobe Magento=2.4.5-p7
Adobe Magento=2.4.6
Adobe Magento=2.4.6-p1
Adobe Magento=2.4.6-p2
Adobe Magento=2.4.6-p3
Adobe Magento=2.4.6-p4
Adobe Magento=2.4.6-p5
Adobe Magento=2.4.7-b1
composer/magento/community-edition<2.4.4-p9
2.4.4-p9
composer/magento/community-edition>=2.4.5-p1, <2.4.5-p8
2.4.5-p8
composer/magento/community-edition>=2.4.6-p1, <2.4.6-p6
2.4.6-p6
composer/magento/community-edition=2.4.4
composer/magento/community-edition=2.4.5
composer/magento/community-edition=2.4.6
composer/magento/community-edition=2.4.7

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/magento/community-edition to a version that resolves this vulnerability.

    Fixed in 2.4.4-p9
  2. Upgrade

    Upgrade composer/magento/community-edition to a version that resolves this vulnerability.

    Fixed in 2.4.5-p8
  3. Upgrade

    Upgrade composer/magento/community-edition to a version that resolves this vulnerability.

    Fixed in 2.4.6-p6

Event History

Jun 13, 2024
CVE Published
via MITRE·09:04 AM
Data Sourced
via MITRE·09:04 AM
DescriptionSeverityWeakness
Data Sourced
via NVD·09:15 AM
DescriptionSeverityWeaknessAffected Software
Advisory Published
via GitHub·09:31 AM
Data Sourced
via GitHub·09:31 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·09:31 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2024-34111?

CVE-2024-34111 has a low severity rating, affecting versions of Adobe Commerce and exposing the system to potential server-side request forgery.

2

How do I fix CVE-2024-34111?

To remediate CVE-2024-34111, you should upgrade to Adobe Commerce version 2.4.4-p9 or later.

3

Which versions are affected by CVE-2024-34111?

CVE-2024-34111 affects Adobe Commerce versions 2.4.7, 2.4.6-p5, 2.4.5-p7, 2.4.4-p8 and earlier.

4

What is a Server-Side Request Forgery (SSRF) vulnerability in CVE-2024-34111?

In the context of CVE-2024-34111, SSRF allows an attacker to send unauthorized requests from the vulnerable server, potentially accessing sensitive resources.

5

Who can exploit CVE-2024-34111?

A low-privilege authenticated attacker can exploit CVE-2024-34111 to make arbitrary requests through the affected Adobe Commerce application.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203