CVE-2024-34467: ThinkPHP Cross-Site Scripting Vulnerability

Published May 4, 2024
·
Updated

ThinkPHP 8.0.3 allows remote attackers to exploit XSS due to inadequate filtering of function argument values in thinkexception.tpl.

Other sources

ThinkPHP Cross-Site Scripting Vulnerability

— Packagist

Affected Software

7 affected componentsFixes available
composer/topthink/framework<6.0.17
6.0.17
composer/topthink/framework>=6.1.0<6.1.5
6.1.5
composer/topthink/framework>=8.0.0<8.0.4
8.0.4
ThinkPHP ThinkPHP=8.0.3
composer/topthink/framework<6.0.17
6.0.17
composer/topthink/framework>=6.1.0, <6.1.5
6.1.5
composer/topthink/framework>=8.0.0, <8.0.4
8.0.4

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/topthink/framework to a version that resolves this vulnerability.

    Fixed in 6.0.17
  2. Upgrade

    Upgrade composer/topthink/framework to a version that resolves this vulnerability.

    Fixed in 6.1.5
  3. Upgrade

    Upgrade composer/topthink/framework to a version that resolves this vulnerability.

    Fixed in 8.0.4

Event History

May 4, 2024
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via NVD·08:15 PM
DescriptionSeverityWeaknessAffected Software
Advisory Published
via GitHub·09:30 PM
Data Sourced
via GitHub·09:30 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·09:30 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2024-34467?

CVE-2024-34467 has a medium severity rating due to the potential for remote attackers to exploit the XSS vulnerability.

2

How do I fix CVE-2024-34467?

To fix CVE-2024-34467, upgrade to version 8.0.4 or apply the necessary patches for your version of the topthink/framework package.

3

Which versions of ThinkPHP are affected by CVE-2024-34467?

CVE-2024-34467 affects ThinkPHP versions prior to 8.0.4, including versions 8.0.0 to 8.0.3 and lower 6.x versions.

4

Can CVE-2024-34467 lead to data breaches?

Yes, CVE-2024-34467 can lead to data breaches through exploitation of XSS, allowing attackers to execute malicious scripts in users' browsers.

5

Is any user input affected by CVE-2024-34467?

Yes, the vulnerability stems from inadequate filtering of function argument values, indicating that user input may be exploited.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203