CVE-2024-34507: XSS
An issue was discovered in includes/CommentFormatter/CommentParser.php in MediaWiki before 1.39.7, 1.40.x before 1.40.3, and 1.41.x before 1.41.1. XSS can occur because of mishandling of the 0x1b character, as demonstrated by Special:RecentChanges#%1b0000000.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/mediawikito a version that resolves this vulnerability.Fixed in 1:1.39.7-1~deb12u1 - Upgrade
Upgrade
debian/mediawikito a version that resolves this vulnerability.Fixed in 1:1.39.7-1 - Upgrade
Upgrade
debian/mediawikito a version that resolves this vulnerability.Fixed in 1:1.39.17-1+deb12u2Fixed in 1:1.43.9+dfsg-1~deb13u1Fixed in 1:1.43.11+dfsg-3
Event History
Frequently Asked Questions
What is the severity of CVE-2024-34507?
CVE-2024-34507 has been classified with a high severity level due to its potential for XSS attacks.
How do I fix CVE-2024-34507?
To fix CVE-2024-34507, upgrade your MediaWiki installation to version 1.39.7, 1.40.3, or 1.41.1 or later.
What software is affected by CVE-2024-34507?
CVE-2024-34507 affects MediaWiki versions prior to 1.39.7, 1.40.x before 1.40.3, and 1.41.x before 1.41.1.
What type of vulnerability is CVE-2024-34507?
CVE-2024-34507 is classified as a cross-site scripting (XSS) vulnerability.
What kind of attack can CVE-2024-34507 enable?
CVE-2024-34507 can enable attackers to execute arbitrary scripts in the context of a user's browser session.