CVE-2024-35840: mptcp: use OPTION_MPTCP_MPJ_SYNACK in subflow_finish_connect()

Published May 17, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

mptcp: use OPTIONMPTCPMPJSYNACK in subflowfinishconnect()

subflowfinishconnect() uses four fields (backup, joinid, thmac, none) that may contain garbage unless OPTIONMPTCPMPJSYNACK has been set in mptcpparseoption()

Other sources

In the Linux kernel, the following vulnerability has been resolved:

mptcp: use OPTIONMPTCPMPJSYNACK in subflowfinishconnect()

The Linux kernel CVE team has assigned CVE-2024-35840 to this issue.

Upstream advisory: https://lore.kernel.org/linux-cve-announce/2024051756-CVE-2024-35840-99fa@gregkh/T

— Red Hat

Affected Software

13 affected componentsFixes available
Linux Linux kernel>=5.7<5.15.148
Linux Linux kernel>=5.16<6.1.75
Linux Linux kernel>=6.2<6.6.14
Linux Linux kernel>=6.7<6.7.2
redhat/kernel<5.15.148
5.15.148
redhat/kernel<6.1.75
6.1.75
redhat/kernel<6.6.14
6.6.14
redhat/kernel<6.7.2
6.7.2
redhat/kernel<6.8
6.8
debian/linux<6.1.76-1
6.1.76-1
debian/linux<6.6.15-1
6.6.15-1
debian/linux<6.6.15-1
6.6.15-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 5.15.148
  2. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.1.75
  3. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.6.14
  4. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.7.2
  5. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.8
  6. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.76-1
  7. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.6.15-1
  8. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1

Event History

May 17, 2024
CVE Published
via MITRE·02:27 PM
Data Sourced
via MITRE·02:27 PM
Description
Data Sourced
via NVD·03:15 PM
RemedyDescriptionSeverityAffected Software
Data Sourced
via OSV·03:15 PM
DescriptionSeverityAffected Software
May 18, 2024
Data Sourced
via Red Hat·12:47 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2024-35840?

CVE-2024-35840 has been classified as a medium severity vulnerability due to its potential impact on data integrity.

2

How do I fix CVE-2024-35840?

To fix CVE-2024-35840, update the Linux kernel to version 5.15.148, 6.1.75, 6.6.14, 6.7.2, 6.8 or applicable versions specified for the affected distributions.

3

Which systems are affected by CVE-2024-35840?

CVE-2024-35840 affects specific versions of the Red Hat kernel and Debian Linux packages.

4

What are the symptoms of CVE-2024-35840 exploitation?

Exploitation of CVE-2024-35840 may result in unexpected behavior during MultiPath TCP connections due to uninitialized fields.

5

Is CVE-2024-35840 related to MultiPath TCP?

Yes, CVE-2024-35840 is specifically related to vulnerabilities in the handling of MultiPath TCP options in the Linux kernel.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203