CVE-2024-35848: eeprom: at24: fix memory corruption race condition
eeprom: at24: fix memory corruption race condition
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 5.10.223-1Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 5.10.217 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 5.15.159 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 6.1.91 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 6.6.31 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 6.8.9 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 6.9 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch CVE-2024-35848
Event History
Frequently Asked Questions
What is the severity of CVE-2024-35848?
CVE-2024-35848 has been classified as a serious vulnerability due to the potential for memory corruption and race condition issues in the Linux kernel.
How do I fix CVE-2024-35848?
To fix CVE-2024-35848, update the Linux kernel to the recommended versions provided by your distribution, such as 5.10.217 or later.
Which Linux kernel versions are affected by CVE-2024-35848?
CVE-2024-35848 affects several kernel versions including prior to 5.10.217, 5.15.159, 6.1.91, and specific versions noted by Red Hat and Debian.
What systems are impacted by CVE-2024-35848?
Systems running vulnerable versions of the Linux kernel, particularly Red Hat and Debian distributions, are impacted by CVE-2024-35848.
Is there a risk of exploitation with CVE-2024-35848?
Yes, there is a risk of exploitation with CVE-2024-35848 due to the potential for unauthorized access and system instability.