CVE-2024-35930: scsi: lpfc: Fix possible memory leak in lpfc_rcv_padisc()

Published May 19, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

scsi: lpfc: Fix possible memory leak in lpfcrcvpadisc()

The call to lpfcsli4resumerpi() in lpfcrcvpadisc() may return an unsuccessful status. In such cases, the elsiocb is not issued, the completion is not called, and thus the elsiocb resource is leaked.

Check return value after calling lpfcsli4resumerpi() and conditionally release the elsiocb resource.

Other sources

In the Linux kernel, the following vulnerability has been resolved:

scsi: lpfc: Fix possible memory leak in lpfcrcvpadisc()

The Linux kernel CVE team has assigned CVE-2024-35930 to this issue.

Upstream advisory: https://lore.kernel.org/linux-cve-announce/2024051916-CVE-2024-35930-5571@gregkh/T

— Red Hat

Affected Software

31 affected componentsFixes available
IBM Security Verify Governance<=ISVG 10.0.2
IBM Security Verify Governance, Identity Manager Software Stack<=ISVG 10.0.2
IBM Security Verify Governance, Identity Manager Virtual Appliance<=ISVG 10.0.2
IBM Security Verify Governance Identity Manager Container<=ISVG 10.0.2
redhat/kernel<4.19.312
4.19.312
redhat/kernel<5.4.274
5.4.274
redhat/kernel<5.10.215
5.10.215
redhat/kernel<5.15.155
5.15.155
redhat/kernel<6.1.86
6.1.86
redhat/kernel<6.6.27
6.6.27
redhat/kernel<6.8.6
6.8.6
redhat/kernel<6.9
6.9
Linux Linux kernel<4.19.312
Linux Linux kernel>=4.20<5.4.274
Linux Linux kernel>=5.5<5.10.215
Linux Linux kernel>=5.11<5.15.155
Linux Linux kernel>=5.16<6.1.86
Linux Linux kernel>=6.2<6.6.27
Linux Linux kernel>=6.7<6.8.6
Debian Debian Linux=10.0
linux/kernel>=3.4.0<4.19.312
4.19.312
linux/kernel>=4.20.0<5.4.274
5.4.274
linux/kernel>=5.5.0<5.10.215
5.10.215
linux/kernel>=5.11.0<5.15.155
5.15.155
linux/kernel>=5.16.0<6.1.86
6.1.86
linux/kernel>=6.2.0<6.6.27
6.6.27
linux/kernel>=6.7.0<6.8.6
6.8.6
debian/linux<6.1.90-1
6.1.90-1
debian/linux<6.8.9-1
6.8.9-1
debian/linux<6.8.9-1
6.8.9-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 4.19.312
  2. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 5.4.274
  3. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 5.10.215
  4. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 5.15.155
  5. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.1.86
  6. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.6.27
  7. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.8.6
  8. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.9
  9. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 4.19.312
  10. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 5.4.274
  11. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 5.10.215
  12. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 5.15.155
  13. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 6.1.86
  14. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 6.6.27
  15. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 6.8.6
  16. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.90-1
  17. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.8.9-1
  18. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1

Event History

May 19, 2024
CVE Published
via MITRE·10:10 AM
Data Sourced
via MITRE·10:10 AM
Description
Data Sourced
via OSV·10:10 AM
DescriptionAffected Software
Data Sourced
via NVD·11:15 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·11:15 AM
Severity
Data Sourced
via Red Hat·03:58 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-35930?

CVE-2024-35930 has been categorized as a medium severity vulnerability involving a potential memory leak in the Linux kernel.

2

How do I fix CVE-2024-35930?

To fix CVE-2024-35930, upgrade to kernel versions 4.19.312, 5.4.274, 5.10.215, 5.15.155, 6.1.86, or later versions as specified by your distribution.

3

What systems are affected by CVE-2024-35930?

CVE-2024-35930 affects various versions of the Linux kernel, particularly those prior to 4.19.312, 5.4.274, 5.10.215, and later versions up to 6.9.

4

What is the impact of CVE-2024-35930?

The impact of CVE-2024-35930 includes a possible memory leak that could lead to system instability or resource exhaustion.

5

Who is responsible for addressing CVE-2024-35930?

Linux kernel maintainers and distribution vendors are responsible for addressing CVE-2024-35930 through patches and updates.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203