CVE-2024-35964: Bluetooth: ISO: Fix not validating setsockopt user input

Published May 20, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

Bluetooth: ISO: Fix not validating setsockopt user input

Check user input length before copying data.

Other sources

In the Linux kernel, the following vulnerability has been resolved:

Bluetooth: ISO: Fix not validating setsockopt user input

The Linux kernel CVE team has assigned CVE-2024-35964 to this issue.

Upstream advisory: https://lore.kernel.org/linux-cve-announce/2024052021-CVE-2024-35964-25e2@gregkh/T

— Red Hat

Affected Software

12 affected componentsFixes available
Linux Linux kernel>=6.0<6.1.119
Linux Linux kernel>=6.2<6.6.55
Linux Linux kernel>=6.7<6.8.7
Linux Linux kernel=6.9-rc1
Linux Linux kernel=6.9-rc2
Linux Linux kernel=6.9-rc3
redhat/kernel<6.8.7
6.8.7
redhat/kernel<6.9
6.9
debian/linux<6.1.119-1
6.1.119-1
debian/linux<6.8.9-1
6.8.9-1
debian/linux<6.8.9-1
6.8.9-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 5.10.223-1Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1
  2. Upgrade

    Upgrade debian/linux-6.1 to a version that resolves this vulnerability.

    Fixed in 6.1.129-1~deb11u1
  3. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.8.7
  4. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.9

Event History

May 20, 2024
CVE Published
via MITRE·09:41 AM
Data Sourced
via MITRE·09:41 AM
Description
Data Sourced
via NVD·10:15 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·10:15 AM
DescriptionSeverityAffected Software
Data Sourced
via Red Hat·04:52 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-35964?

CVE-2024-35964 is classified as a medium severity vulnerability due to improper user input validation.

2

How do I fix CVE-2024-35964?

To fix CVE-2024-35964, upgrade to the patched Linux kernel versions 5.10.223-1, 5.10.226-1, 6.1.119-1 or later.

3

What software is affected by CVE-2024-35964?

CVE-2024-35964 affects specific versions of the Linux kernel, including 5.10, 6.1, and 6.12.

4

What type of vulnerability is CVE-2024-35964?

CVE-2024-35964 is a validation vulnerability in the Bluetooth subsystem of the Linux kernel.

5

Can CVE-2024-35964 be exploited remotely?

Yes, CVE-2024-35964 has the potential to be exploited remotely due to its nature involving Bluetooth communication.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203