CVE-2024-36387: Apache HTTP Server: DoS by Null pointer in websocket over HTTP/2

Published Jul 1, 2024
·
Updated

Last updated 24 July 2024

Other sources

Serving WebSocket protocol upgrades over a HTTP/2 connection could result in a Null Pointer dereference, leading to a crash of the server process, degrading performance.

— NVD

Affected Software

14 affected componentsFixes available
Apache HTTP Server>=2.4.55<=2.4.59
NetApp Ontap=9
alpine/apache2<2.4.60-r0
2.4.60-r0
alpine/apache2<2.4.60-r0
2.4.60-r0
alpine/apache2<2.4.60-r0
2.4.60-r0
alpine/apache2<2.4.60-r0
2.4.60-r0
alpine/apache2<2.4.60-r0
2.4.60-r0
alpine/apache2<2.4.60-r0
2.4.60-r0
alpine/apache2<2.4.60-r0
2.4.60-r0
alpine/apache2<2.4.60-r0
2.4.60-r0
debian/apache2<2.4.61-1~deb12u1
2.4.61-1~deb12u1
debian/apache2<2.4.60-1
2.4.60-1
debian/apache2<2.4.60-1
2.4.60-1
debian/apache2
2.4.68-1~deb12u12.4.67-1~deb12u32.4.68-1~deb13u12.4.69-1~deb13u12.4.69-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade alpine/apache2 to a version that resolves this vulnerability.

    Fixed in 2.4.60-r0
  2. Upgrade

    Upgrade debian/apache2 to a version that resolves this vulnerability.

    Fixed in 2.4.61-1~deb12u1
  3. Upgrade

    Upgrade debian/apache2 to a version that resolves this vulnerability.

    Fixed in 2.4.60-1
  4. Upgrade

    Upgrade debian/apache2 to a version that resolves this vulnerability.

    Fixed in 2.4.68-1~deb12u1Fixed in 2.4.67-1~deb12u3Fixed in 2.4.68-1~deb13u1Fixed in 2.4.69-1~deb13u1Fixed in 2.4.69-1

Event History

Jul 1, 2024
CVE Published
via MITRE·06:10 PM
Data Sourced
via MITRE·06:10 PM
DescriptionWeakness
Data Sourced
via NVD·07:15 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·07:15 PM
DescriptionSeverityAffected Software
Data Sourced
via Red Hat·07:20 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2024-36387?

CVE-2024-36387 has a severity rating that indicates it can lead to server crashes and performance degradation.

2

How do I fix CVE-2024-36387?

To fix CVE-2024-36387, update your Apache2 package to versions 2.4.62-1~deb11u1, 2.4.61-1~deb11u1, 2.4.62-1~deb12u1, 2.4.62-1~deb12u2, or 2.4.62-3.

3

What causes the vulnerability CVE-2024-36387?

CVE-2024-36387 is caused by serving WebSocket protocol upgrades over HTTP/2 connections, which can lead to a Null Pointer dereference.

4

Who is affected by CVE-2024-36387?

CVE-2024-36387 affects users running specific versions of the Apache2 web server under Debian.

5

What are the potential impacts of CVE-2024-36387?

The potential impacts of CVE-2024-36387 include crashes of the server process and degraded performance.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203