CVE-2024-37535: vte 0.76.3 leased with fix for CVE-2024-37535

Published Jun 9, 2024
·
Updated

GNOME VTE before 0.76.3 allows an attacker to cause a denial of service (memory consumption) via a window resize escape sequence a related issue to CVE-2000-0476.

Other sources

GNOME VTE before 0.76.3 allows an attacker to cause a denial of service (memory consumption) via a window resize escape sequence, a related issue to CVE-2000-0476.

— NVD

Affected Software

13 affected componentsFixes available
Gnome VTE<0.76.3
Microsoft azl3 vte291 0.74.2-6
Microsoft cbl2 vte291 0.66.2-3
Microsoft azl3 vte291 0.74.2-7
Microsoft cbl2 vte291 0.66.2-4
debian/vte*
debian/vte*
debian/vte*
debian/vte2.91*
debian/vte2.91<0.76.3-6
0.76.3-6
debian/vte2.91<0.76.3-6
0.76.3-6
debian/vte<=1:0.28.2-6, <=1:0.28.2-7
debian/vte2.91<=0.70.6-2~deb12u1
0.80.1-10.84.1-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/vte2.91 to a version that resolves this vulnerability.

    Fixed in 0.76.3-6
  2. Upgrade

    Upgrade debian/vte2.91 to a version that resolves this vulnerability.

    Fixed in 0.80.1-1Fixed in 0.84.1-1
  3. Upgrade

    Upgrade GNOME VTE to a version that resolves this vulnerability.

    Fixed in 0.76.3

Event History

Jun 9, 2024
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via NVD·03:16 PM
DescriptionSeverityWeakness
Data Sourced
via OSV·03:16 PM
DescriptionSeverityAffected Software
Jun 30, 2024
Data Sourced
via Microsoft·02:00 PM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2024-37535?

CVE-2024-37535 is classified as a denial of service vulnerability that can lead to memory consumption.

2

How do I fix CVE-2024-37535?

To fix CVE-2024-37535, upgrade GNOME VTE to version 0.76.3 or later.

3

Which versions of GNOME VTE are affected by CVE-2024-37535?

GNOME VTE versions prior to 0.76.3 are affected by CVE-2024-37535.

4

What kind of attack does CVE-2024-37535 enable?

CVE-2024-37535 allows an attacker to cause a denial of service through a window resize escape sequence.

5

Is CVE-2024-37535 related to any other vulnerabilities?

CVE-2024-37535 is related to CVE-2000-0476 as both involve issues that can lead to denial of service.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203