CVE-2024-37894: Squid vulnerable to heap corruption in ESI assign

Published Jun 25, 2024
·
Updated

Last updated 25 July 2024

Other sources

Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Due to an Out-of-bounds Write error when assigning ESI variables, Squid is susceptible to a Memory Corruption error. This error can lead to a Denial of Service attack.

— NVD

Affected Software

5 affected componentsFixes available
Squid-Cache Squid>=3.0<6.10
debian/squid<5.7-2+deb12u2
5.7-2+deb12u2
debian/squid<6.10-1
6.10-1
debian/squid<6.10-1
6.10-1
debian/squid
5.7-2+deb12u55.7-2+deb12u66.13-2+deb13u36.13-2+deb13u47.8-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/squid to a version that resolves this vulnerability.

    Fixed in 5.7-2+deb12u2
  2. Upgrade

    Upgrade debian/squid to a version that resolves this vulnerability.

    Fixed in 6.10-1
  3. Upgrade

    Upgrade debian/squid to a version that resolves this vulnerability.

    Fixed in 5.7-2+deb12u5Fixed in 5.7-2+deb12u6Fixed in 6.13-2+deb13u3Fixed in 6.13-2+deb13u4Fixed in 7.8-1
  4. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Patch GHSA-wgvf-q977-9xjg

Event History

Jun 25, 2024
CVE Published
via MITRE·07:39 PM
Data Sourced
via MITRE·07:39 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·08:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·08:15 PM
DescriptionSeverityAffected Software
Jun 26, 2024
Data Sourced
via Red Hat·01:09 AM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-37894?

CVE-2024-37894 has a high severity rating due to the potential for memory corruption leading to Denial of Service attacks.

2

How do I fix CVE-2024-37894?

To fix CVE-2024-37894, upgrade Squid to version 5.7-2+deb12u2 or 6.10-1 if you are using a version that is affected.

3

What versions of Squid are affected by CVE-2024-37894?

CVE-2024-37894 affects Squid versions up to inclusive 4.13-10+deb11u3.

4

What type of attack can CVE-2024-37894 lead to?

CVE-2024-37894 can lead to Denial of Service attacks due to a memory corruption error.

5

Is there any workaround for CVE-2024-37894?

There are no known workarounds for CVE-2024-37894, so upgrading is essential for security.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203