CVE-2024-38274: Moodle stored XSS via calendar's event title when deleting the event
Insufficient escaping of calendar event titles resulted in a stored XSS risk in the event deletion prompt.
Other sources
Moodle stored XSS via calendar's event title when deleting the event
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 4.1.11 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 4.2.8 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 4.3.5 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 4.4.1
Event History
Frequently Asked Questions
What is the severity of CVE-2024-38274?
CVE-2024-38274 has been classified with a medium severity due to its potential for stored cross-site scripting (XSS).
How do I fix CVE-2024-38274?
You can fix CVE-2024-38274 by upgrading to Moodle version 4.1.11, 4.2.8, 4.3.5, or 4.4.1 or later.
What is the impact of CVE-2024-38274?
CVE-2024-38274 can lead to a stored XSS vulnerability that affects the security of user data and application integrity.
Which versions of Moodle are affected by CVE-2024-38274?
CVE-2024-38274 affects versions of Moodle prior to 4.1.11, 4.2.8, 4.3.5, and 4.4.1.
Is there a workaround for CVE-2024-38274?
There are no reported workarounds for CVE-2024-38274; the recommended action is to upgrade to a patched version.