CVE-2024-38587: speakup: Fix sizeof() vs ARRAY_SIZE() bug

Published Jun 19, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

speakup: Fix sizeof() vs ARRAYSIZE() bug

The "buf" pointer is an array of u16 values. This code should be using ARRAYSIZE() (which is 256) instead of sizeof() (which is 512), otherwise it can the still got out of bounds.

Affected Software

12 affected componentsFixes available
Linux Linux kernel>=4.19.313<4.19.316
Linux Linux kernel>=5.4.275<5.4.278
Linux Linux kernel>=5.10.216<5.10.219
Linux Linux kernel>=5.15.157<5.15.161
Linux Linux kernel>=6.1.88<6.1.93
Linux Linux kernel>=6.6.29<6.6.33
Linux Linux kernel>=6.8.8<6.8.12
Linux Linux kernel>=6.9<6.9.3
debian/linux<6.1.94-1
6.1.94-1
debian/linux<6.8.12-1
6.8.12-1
debian/linux<6.8.12-1
6.8.12-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.94-1
  2. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.8.12-1
  3. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1
  4. Compensating control

    Verify the speakup code uses ARRAY_SIZE() (256) instead of sizeof() (512) for the u16 buf array to prevent out-of-bounds access.

Event History

Jun 19, 2024
CVE Published
via MITRE·01:37 PM
Data Sourced
via MITRE·01:37 PM
DescriptionSeverity
Data Sourced
via NVD·02:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·02:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-38587?

CVE-2024-38587 is classified as a medium severity vulnerability in the Linux kernel.

2

How do I fix CVE-2024-38587?

To fix CVE-2024-38587, update your Linux kernel to version 5.10.223-1, 5.10.226-1, 6.1.119-1, 6.1.123-1, 6.12.10-1, or 6.12.11-1.

3

What software is affected by CVE-2024-38587?

CVE-2024-38587 affects specific versions of the Linux package in the Debian distribution.

4

What causes CVE-2024-38587?

CVE-2024-38587 is caused by a bug in the speakup driver where sizeof() is incorrectly used instead of ARRAY_SIZE().

5

Is there a workaround for CVE-2024-38587?

Currently, the recommended course of action for CVE-2024-38587 is to apply the available kernel updates rather than trying to implement a workaround.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203