CVE-2024-38588: ftrace: Fix possible use-after-free issue in ftrace_location()

Published Jun 19, 2024
·
Updated

ftrace: Fix possible use-after-free issue in ftracelocation()

Affected Software

16 affected componentsFixes available
Linux Linux kernel>=3.7<6.1.93
Linux Linux kernel>=6.2<6.6.33
Linux Linux kernel>=6.7<6.8.12
Linux Linux kernel>=6.9<6.9.3
Debian Debian Linux=11.0
Linux Linux kernel>=3.7<5.4.286
Linux Linux kernel>=5.5<5.10.227
Linux Linux kernel>=5.11<5.15.162
Linux Linux kernel>=5.16<6.1.93
Microsoft cbl2 kernel 5.15.180.1-1
Microsoft cbl2 kernel 5.15.180.1-1
Microsoft cbl2 kernel 5.15.162.2-1
debian/linux<6.1.94-1
6.1.94-1
debian/linux<6.8.12-1
6.8.12-1
debian/linux<6.8.12-1
6.8.12-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.94-1
  2. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.8.12-1
  3. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1
  4. Configuration

    In ftrace_location(), replace use of lookup_rec() with ftrace_location_range() to avoid a possible use-after-free in ftrace pages during module deletion.

    Linux kernel ftrace/kprobe ftrace_location() implementation = Use ftrace_location_range() instead of lookup_rec()
  5. Compensating control

    Add/ensure RCU synchronization when freeing or accessing ftrace pages: call synchronize_rcu() before freeing any ftrace pages in ftrace_process_locs()/ftrace_release_mod()/ftrace_free_mem(), and hold the RCU lock while accessing ftrace pages in ftrace_location_range().

Event History

Jun 19, 2024
CVE Published
via MITRE·01:37 PM
Data Sourced
via MITRE·01:37 PM
DescriptionSeverity
Data Sourced
via NVD·02:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·02:15 PM
DescriptionSeverityAffected Software
Oct 12, 2024
Data Sourced
via Microsoft·07:00 AM
DescriptionSeverityWeaknessAffected Software

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-38588?

CVE-2024-38588 is classified as a medium severity vulnerability due to its potential for exploitation through use-after-free issues.

2

How do I fix CVE-2024-38588?

To fix CVE-2024-38588, update your Linux kernel to version 6.1.123-1, 6.1.119-1, 6.12.11-1, or 6.12.12-1.

3

Which Linux kernel versions are affected by CVE-2024-38588?

CVE-2024-38588 affects Linux kernel versions between 3.7 and 6.1.93, as well as versions from 6.2 to 6.6.33, 6.7 to 6.8.12, and 6.9 to 6.9.3.

4

How does CVE-2024-38588 impact system security?

CVE-2024-38588 can potentially allow local attackers to exploit use-after-free conditions, compromising system stability and security.

5

Is there a workaround for CVE-2024-38588?

There are no widely recommended workarounds for CVE-2024-38588; updating the kernel is the primary solution.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203