CVE-2024-38590: RDMA/hns: Modify the print level of CQE error
In the Linux kernel, the following vulnerability has been resolved:
RDMA/hns: Modify the print level of CQE error
Too much print may lead to a panic in kernel. Change ibdeverr() to ibdeverrratelimited(), and change the printing level of cqe dump to debug level.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.94-1 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.8.12-1 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1 - Configuration
Change ibdev_err() to ibdev_err_ratelimited() in RDMA/hns code to rate-limit CQE error printing.
Linux kernel (RDMA/hns) ibdev_err() call = ibdev_err_ratelimited() - Configuration
Change the printing level of CQE dump from the current level to debug to reduce log volume and avoid kernel panic risk.
Linux kernel (RDMA/hns) printing level for cqe dump = debug
Event History
Frequently Asked Questions
What is the severity of CVE-2024-38590?
CVE-2024-38590 has a moderate severity level due to potential kernel panic caused by excessive error logging.
How do I fix CVE-2024-38590?
To fix CVE-2024-38590, update your Linux kernel to one of the fixed versions, such as 5.10.223-1, 6.1.123-1, or higher.
Which versions of the Linux kernel are affected by CVE-2024-38590?
CVE-2024-38590 affects Linux kernel versions prior to 5.10.223, 6.1.123, and other specified versions.
What components are involved in CVE-2024-38590?
CVE-2024-38590 involves the RDMA subsystem of the Linux kernel, particularly related to error logging in the error handling of Completion Queue Entries.
Is CVE-2024-38590 publicly known?
Yes, CVE-2024-38590 is publicly known and reported in security advisories related to the Linux kernel.