CVE-2024-38807: Signature Forgery Vulnerability in Spring Boot's Loader
Applications that use spring-boot-loader or spring-boot-loader-classic and contain custom code that performs signature verification of nested jar files may be vulnerable to signature forgery where content that appears to have been signed by one signer has, in fact, been signed by another.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
maven/org.springframework.boot:spring-boot-loader-classicto a version that resolves this vulnerability.Fixed in 3.3.3 - Upgrade
Upgrade
maven/org.springframework.boot:spring-boot-loaderto a version that resolves this vulnerability.Fixed in 3.3.3 - Upgrade
Upgrade
maven/org.springframework.boot:spring-boot-loader-classicto a version that resolves this vulnerability.Fixed in 3.2.9 - Upgrade
Upgrade
maven/org.springframework.boot:spring-boot-loaderto a version that resolves this vulnerability.Fixed in 3.2.9 - Upgrade
Upgrade
maven/org.springframework.boot:spring-boot-loader-classicto a version that resolves this vulnerability.Fixed in 3.1.13 - Upgrade
Upgrade
maven/org.springframework.boot:spring-boot-loaderto a version that resolves this vulnerability.Fixed in 3.1.13 - Upgrade
Upgrade
maven/org.springframework.boot:spring-boot-loader-classicto a version that resolves this vulnerability.Fixed in 3.0.17 - Upgrade
Upgrade
maven/org.springframework.boot:spring-boot-loaderto a version that resolves this vulnerability.Fixed in 3.0.17 - Upgrade
Upgrade
maven/org.springframework.boot:spring-boot-loader-classicto a version that resolves this vulnerability.Fixed in 2.7.22 - Upgrade
Upgrade
maven/org.springframework.boot:spring-boot-loaderto a version that resolves this vulnerability.Fixed in 2.7.22
Event History
Frequently Asked Questions
What is the severity of CVE-2024-38807?
CVE-2024-38807 is classified as a high-severity vulnerability due to its potential for signature forgery in applications.
How do I fix CVE-2024-38807?
To mitigate CVE-2024-38807, upgrade to spring-boot-loader or spring-boot-loader-classic version 3.3.3 or higher for compatibility.
Which versions are affected by CVE-2024-38807?
CVE-2024-38807 affects multiple versions of spring-boot-loader and spring-boot-loader-classic from version 3.3.0 to 3.3.2, 3.2.0 to 3.2.8, 3.1.0 to 3.1.12, and 3.0.0 to 3.0.16.
What types of applications are vulnerable due to CVE-2024-38807?
Applications that utilize spring-boot-loader or spring-boot-loader-classic with custom code for signature verification of nested JAR files are vulnerable due to CVE-2024-38807.
Is CVE-2024-38807 specific to a certain software package?
Yes, CVE-2024-38807 specifically impacts the spring-boot-loader and spring-boot-loader-classic packages from the Spring Boot framework.