CVE-2024-39329: Django CVE-2024-38875, CVE-2024-39329, CVE-2024-39330, and CVE-2024-39614

Published Jul 5, 2024
·
Updated

An issue was discovered in Django 5.0 before 5.0.7 and 4.2 before 4.2.14. The django.contrib.auth.backends.ModelBackend.authenticate() method allows remote attackers to enumerate users via a timing attack involving login requests for users with an unusable password.

Other sources

An issue was discovered in Django 5.0 before 5.0.7 and 4.2 before 4.2.14. The django.contrib.auth.backends.ModelBackend.authenticate() method allows remote attackers to enumerate users via a timing attack involving login requests for users with an unusable password.

— NVD

Django could allow a remote attacker to obtain sensitive information, caused by a flaw in the contrib.auth.backends.ModelBackend.authenticate() method. By utilize timing attack techniques, an attacker could exploit this vulnerability to enumerate users information, and use this information to launch further attacks against the affected system.

— IBM

The django.contrib.auth.backends.ModelBackend.authenticate() method allows remote attackers to enumerate users via a timing attack involving login requests for users with unusable passwords.

Affected versions =================

Django main development branch Django 5.1 Django 5.0 Django 4.2

— Red Hat

Affected Software

14 affected componentsFixes available
pip/django>=4.2<4.2.14
4.2.14
pip/django>=5.0<5.0.7
5.0.7
IBM Storage Defender - Resiliency Service<=2.0.0 - 2.0.9
djangoproject Django>=4.2<4.2.14
djangoproject Django>=5.0<5.0.7
debian/python-django<3:3.2.25-0+deb12u1
3:3.2.25-0+deb12u1
debian/python-django<3:4.2.14-1
3:4.2.14-1
debian/python-django<3:4.2.14-1
3:4.2.14-1
alpine/py3-django<4.2.16-r0
4.2.16-r0
alpine/py3-django<4.2.16-r0
4.2.16-r0
alpine/py3-django<4.2.16-r0
4.2.16-r0
alpine/py3-django<4.2.16-r0
4.2.16-r0
alpine/py3-django<4.2.16-r0
4.2.16-r0
debian/python-django
3:3.2.25-0+deb12u33:3.2.25-0+deb12u63:4.2.28-0+deb13u23:4.2.28-0+deb13u13:5.2.17-23:5.2.19-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade pip/Django to a version that resolves this vulnerability.

    Fixed in 4.2.14
  2. Upgrade

    Upgrade pip/Django to a version that resolves this vulnerability.

    Fixed in 5.0.7
  3. Upgrade

    Upgrade debian/python-django to a version that resolves this vulnerability.

    Fixed in 3:3.2.25-0+deb12u1
  4. Upgrade

    Upgrade debian/python-django to a version that resolves this vulnerability.

    Fixed in 3:4.2.14-1
  5. Upgrade

    Upgrade alpine/py3-django to a version that resolves this vulnerability.

    Fixed in 4.2.16-r0
  6. Upgrade

    Upgrade debian/python-django to a version that resolves this vulnerability.

    Fixed in 3:3.2.25-0+deb12u3Fixed in 3:3.2.25-0+deb12u6Fixed in 3:4.2.28-0+deb13u2Fixed in 3:4.2.28-0+deb13u1Fixed in 3:5.2.17-2Fixed in 3:5.2.19-1
  7. Upgrade

    Upgrade Django to a version that resolves this vulnerability.

    Fixed in 5.0.7
  8. Upgrade

    Upgrade Django to a version that resolves this vulnerability.

    Fixed in 4.2.14

Event History

Jul 5, 2024
Data Sourced
via Red Hat·09:58 AM
DescriptionSeverityAffected Software
Jul 10, 2024
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via NVD·05:15 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·05:15 AM
DescriptionSeverityAffected Software
Advisory Published
via GitHub·06:33 AM
Dec 18, 2024
Data Sourced
via IBM·12:00 AM
DescriptionAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-39329?

CVE-2024-39329 is classified as a security vulnerability that allows remote attackers to enumerate users.

2

How do I fix CVE-2024-39329?

To fix CVE-2024-39329, upgrade Django to version 5.0.7 or 4.2.14.

3

Which Django versions are affected by CVE-2024-39329?

CVE-2024-39329 affects Django versions 5.0 up to 5.0.6 and 4.2 up to 4.2.13.

4

What kind of attack does CVE-2024-39329 involve?

CVE-2024-39329 involves a timing attack that can be used to enumerate users based on login attempts.

5

Is there a workaround for CVE-2024-39329?

There are no specific workarounds documented for CVE-2024-39329 other than upgrading to a secure version.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203