CVE-2024-39398: Magento does not properly restrict excessive authentication attempts

Published Aug 14, 2024
·
Updated

Adobe Commerce versions 2.4.7-p1, 2.4.6-p6, 2.4.5-p8, 2.4.4-p9 and earlier are affected by an Improper Restriction of Excessive Authentication Attempts vulnerability that could result in a security feature bypass. An attacker could exploit this vulnerability to perform brute force attacks and potentially gain unauthorized access to accounts. Exploitation of this issue does not require user interaction, but attack complexity is high.

Other sources

Magento does not properly restrict excessive authentication attempts

— Packagist

Magento versions 2.4.7-p1, 2.4.6-p6, 2.4.5-p8, 2.4.4-p9 and earlier are affected by an Improper Restriction of Excessive Authentication Attempts vulnerability that could result in a security feature bypass. An attacker could exploit this vulnerability to perform brute force attacks and potentially gain unauthorized access to accounts. Exploitation of this issue does not require user interaction, but attack complexity is high.

— GitHub

Affected Software

80 affected componentsFixes available
Adobe Commerce<=2.4.3
Adobe Commerce=2.4.4
Adobe Commerce=2.4.4-p1
Adobe Commerce=2.4.4-p2
Adobe Commerce=2.4.4-p3
Adobe Commerce=2.4.4-p4
Adobe Commerce=2.4.4-p5
Adobe Commerce=2.4.4-p6
Adobe Commerce=2.4.4-p7
Adobe Commerce=2.4.4-p8
Adobe Commerce=2.4.4-p9
Adobe Commerce=2.4.5
Adobe Commerce=2.4.5-p1
Adobe Commerce=2.4.5-p2
Adobe Commerce=2.4.5-p3
Adobe Commerce=2.4.5-p4
Adobe Commerce=2.4.5-p5
Adobe Commerce=2.4.5-p6
Adobe Commerce=2.4.5-p7
Adobe Commerce=2.4.5-p8
Adobe Commerce=2.4.6
Adobe Commerce=2.4.6-p1
Adobe Commerce=2.4.6-p2
Adobe Commerce=2.4.6-p3
Adobe Commerce=2.4.6-p4
Adobe Commerce=2.4.6-p5
Adobe Commerce=2.4.6-p6
Adobe Commerce=2.4.7
Adobe Commerce=2.4.7-b1
Adobe Commerce=2.4.7-b2
Adobe Commerce=2.4.7-p1
Adobe Magento<=2.4.3
Adobe Magento=2.4.4
Adobe Magento=2.4.4-p1
Adobe Magento=2.4.4-p2
Adobe Magento=2.4.4-p3
Adobe Magento=2.4.4-p4
Adobe Magento=2.4.4-p5
Adobe Magento=2.4.4-p6
Adobe Magento=2.4.4-p7
Adobe Magento=2.4.4-p8
Adobe Magento=2.4.4-p9
Adobe Magento=2.4.5
Adobe Magento=2.4.5-p1
Adobe Magento=2.4.5-p2
Adobe Magento=2.4.5-p3
Adobe Magento=2.4.5-p4
Adobe Magento=2.4.5-p5
Adobe Magento=2.4.5-p6
Adobe Magento=2.4.5-p7
Adobe Magento=2.4.5-p8
Adobe Magento=2.4.6
Adobe Magento=2.4.6-p1
Adobe Magento=2.4.6-p2
Adobe Magento=2.4.6-p3
Adobe Magento=2.4.6-p4
Adobe Magento=2.4.6-p5
Adobe Magento=2.4.6-p6
Adobe Magento=2.4.7
Adobe Magento=2.4.7-b1
Adobe Magento=2.4.7-b2
Adobe Magento=2.4.7-p1
composer/magento/project-community-edition<=2.0.2
composer/magento/community-edition=2.4.4
composer/magento/community-edition=2.4.5
composer/magento/community-edition=2.4.6
composer/magento/community-edition=2.4.7
composer/magento/community-edition>=2.4.4-p1, <2.4.4-p10
2.4.4-p10
composer/magento/community-edition>=2.4.5-p1, <2.4.5-p9
2.4.5-p9
composer/magento/community-edition>=2.4.6-p1, <2.4.6-p7
2.4.6-p7
composer/magento/community-edition>=2.4.7-beta1, <2.4.7-p2
2.4.7-p2
composer/magento/community-edition=2.4.4
composer/magento/community-edition=2.4.5
composer/magento/community-edition=2.4.6
composer/magento/community-edition=2.4.7
composer/magento/community-edition>=2.4.4-p1<2.4.4-p10
2.4.4-p10
composer/magento/community-edition>=2.4.5-p1<2.4.5-p9
2.4.5-p9
composer/magento/community-edition>=2.4.6-p1<2.4.6-p7
2.4.6-p7
composer/magento/community-edition>=2.4.7-beta1<2.4.7-p2
2.4.7-p2
composer/magento/project-community-edition<=2.0.2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/magento/community-edition to a version that resolves this vulnerability.

    Fixed in 2.4.4-p10
  2. Upgrade

    Upgrade composer/magento/community-edition to a version that resolves this vulnerability.

    Fixed in 2.4.5-p9
  3. Upgrade

    Upgrade composer/magento/community-edition to a version that resolves this vulnerability.

    Fixed in 2.4.6-p7
  4. Upgrade

    Upgrade composer/magento/community-edition to a version that resolves this vulnerability.

    Fixed in 2.4.7-p2

Event History

Aug 14, 2024
CVE Published
via MITRE·11:57 AM
Data Sourced
via MITRE·11:57 AM
DescriptionSeverityWeakness
Data Sourced
via NVD·12:15 PM
DescriptionSeverityWeaknessAffected Software
Advisory Published
via GitHub·12:35 PM
Data Sourced
via GitHub·12:35 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·12:35 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2024-39398?

The severity of CVE-2024-39398 is considered medium, as it allows for excessive authentication attempts leading to potential brute force attacks.

2

How do I fix CVE-2024-39398?

To fix CVE-2024-39398, update Adobe Commerce to version 2.4.4-p10 or later, 2.4.5-p9 or later, or 2.4.6-p7 or later.

3

Which Adobe Commerce versions are affected by CVE-2024-39398?

Adobe Commerce versions 2.4.7-p1, 2.4.6-p6, 2.4.5-p8, 2.4.4-p9 and earlier are affected by CVE-2024-39398.

4

What type of vulnerability is CVE-2024-39398?

CVE-2024-39398 is categorized as an Improper Restriction of Excessive Authentication Attempts vulnerability.

5

Can CVE-2024-39398 lead to security feature bypass?

Yes, CVE-2024-39398 can potentially allow an attacker to bypass security features through brute force attempts.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203