CVE-2024-39482: bcache: fix variable length array abuse in btree_iter

Published Jul 5, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

bcache: fix variable length array abuse in btreeiter

btreeiter is used in two ways: either allocated on the stack with a fixed size MAXBSETS, or from a mempool with a dynamic size based on the specific cache set. Previously, the struct had a fixed-length array of size MAXBSETS which was indexed out-of-bounds for the dynamically-sized iterators, which causes UBSAN to complain.

This patch uses the same approach as in bcachefs's sortiter and splits the iterator into a btreeiter with a flexible array member and a btreeiterstack which embeds a btreeiter as well as a fixed-length data array.

Affected Software

9 affected componentsFixes available
Linux Linux kernel>=5.10<5.10.221
Linux Linux kernel>=5.15<5.15.162
Linux Linux kernel>=6.1<6.1.94
Linux Linux kernel>=6.6<6.6.34
Linux Linux kernel>=6.9<6.9.5
debian/linux<6.1.94-1
6.1.94-1
debian/linux<6.9.7-1
6.9.7-1
debian/linux<6.9.7-1
6.9.7-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.94-1
  2. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.9.7-1
  3. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1

Event History

Jul 5, 2024
CVE Published
via MITRE·06:55 AM
Data Sourced
via MITRE·06:55 AM
DescriptionSeverity
Data Sourced
via NVD·07:15 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·07:15 AM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2024-39482?

CVE-2024-39482 is classified with a severity rating that indicates potential impact depending on exploitation factors.

2

How do I fix CVE-2024-39482?

To fix CVE-2024-39482, update the Linux kernel to versions 5.10.223-1, 5.10.226-1, 6.1.123-1, or 6.12.11-1.

3

What software is affected by CVE-2024-39482?

CVE-2024-39482 affects multiple versions of the Linux kernel, specifically versions between 5.10 and 6.6.

4

Can CVE-2024-39482 be exploited remotely?

CVE-2024-39482 may allow less privileged users to escalate privileges, potentially leading to remote exploitation under specific conditions.

5

What are the consequences of CVE-2024-39482 if left unpatched?

If left unpatched, CVE-2024-39482 may lead to unauthorized access and manipulation of system resources, posing a security risk.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203