CVE-2024-40938: landlock: Fix d_parent walk

Published Jul 12, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

landlock: Fix dparent walk

The WARNONONCE() in collectdomainaccesses() can be triggered when trying to link a root mount point. This cannot work in practice because this directory is mounted, but the VFS check is done after the call to securitypathlink().

Do not use source directory's dparent when the source directory is the mount point.

[mic: Fix commit message]

Affected Software

8 affected componentsFixes available
Linux Linux kernel>=5.19<6.1.95
Linux Linux kernel>=6.2<6.6.35
Linux Linux kernel>=6.7<6.9.6
Linux Linux kernel=6.10-rc1
debian/linux<6.1.99-1
6.1.99-1
debian/linux<6.9.7-1
6.9.7-1
debian/linux<6.9.7-1
6.9.7-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.99-1
  2. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.9.7-1
  3. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1
  4. Compensating control

    In the Landlock d_parent walk, do not use the source directory's d_parent when the source directory is the mount point.

Event History

Jul 12, 2024
CVE Published
via MITRE·12:25 PM
Data Sourced
via MITRE·12:25 PM
Description
Data Sourced
via NVD·01:15 PM
RemedyDescriptionSeverityAffected Software
Data Sourced
via OSV·01:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-40938?

The severity of CVE-2024-40938 is classified as moderate due to its potential impact on system stability.

2

How do I fix CVE-2024-40938?

To fix CVE-2024-40938, update your Linux kernel to version 5.10.223-1, 5.10.226-1, 6.1.119-1, 6.1.123-1, 6.12.11-1, or 6.12.12-1.

3

Which Linux distributions are affected by CVE-2024-40938?

CVE-2024-40938 affects Debian-based Linux distributions that are using the specified vulnerable kernel versions.

4

What is the nature of CVE-2024-40938?

CVE-2024-40938 is a vulnerability related to the Landlock security module in the Linux kernel affecting directory linking.

5

Is there any known exploit for CVE-2024-40938?

As of now, there are no known public exploits specifically targeting CVE-2024-40938.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203